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1. Abstrakt 

Produktentwicklungszyklen, Kostendruck, Konkurrenz, um nur ein paar Stichpunkte des heutigen 
Konstruktionsalltages zu beschreiben, fordern hochperformante Systeme und High-Professional 
als deren Anwender. 
Moderne CAD-Systeme helfen dem Konstrukteur bei der Erstellung von digitalen Objekten. 
Hierbei werden nicht nur die Bauteile sowie Zeichnungen erstellt, sondern Produkte über einen 
ganzen Lebenszyklus geplant, analysiert und begleitet. 
 
CATIA V5 ist ein System das diese Voraussetzungen als PLM (Product-Lifecycle-Management) 
erfüllt. Die erzeugten Geometrien besitzen nicht nur geometrische Definitionen sondern auch 
produktspezifische, parametrische Eigenschaften. 
Durch logische Verknüpfungen werden Beziehungen (Links) zwischen Baugruppen, Bauteilen, 
Zeichnungen sowie anderen, externen Objekten, aufgebaut, die für den 
Produktentwicklungsprozess relevant sind. 
 
Ziel dieser Entwicklung ist es den Konstruktionsprozess zu optimieren. Zur Optimierung zählen 
unter anderem Kosten (Entwicklungskosten, Änderungskosten, etc.), Wirtschaftlichkeit, 
Nachhaltigkeit sowie Wissensaufbau (Knowledge). 
 
Durch ein optimales Link Management erhöht sich der Konstruktionsaufwand zu Beginn eines 
Produktentwicklungsprozesses. Sobald erste Änderungen (ausgelöst durch Kunden, 
physikalische- sowie fertigungsgerechte Grenzen, etc.) auftreten wird durch die 
Änderungsgeschwindigkeit sowie Änderungssicherheit dieser Nachteil minimiert bis es 
schließlich zu einem ROI (Return of Investment) kommt. 
 
Zur optimalen Anwendung des Link Management mit CATIA V5 ist es wichtig die Hintergründe 
der Software zu kennen und zu nutzen. Dieses Skript soll diese aufzeigen und dem Konstrukteur 
als Nachschalgewerk dienen. 
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2. Strukturierung von nativen CATIA V5 Dateien 

Der Aufbau eines nativen CATIA V5 Produkts (3 dimensionaler Datensatz) ist dem 
fertigungsgerechten Aufbau eines realen Produkts nachempfunden. Hiernach besteht ein 
Produkt aus einer Anzahl n von Unterprodukten (Baugruppen) sowie Bauteilen. 
In CATIA V5 bestehen Produkte (*.CATProduct) ebenso aus Unterbaugruppen (*.CATProduct) 
und Bauteilen (*.CATPart). Hierbei kann ein Hauptprodukt genauso wie ein reales Produkt 
mehrere Unterbaugruppen (die wiederrum Unterbaugruppen aufnehmen können) besitzen, die 
alle ein oder mehrere Bauteile beinhalten. 
 
Jedes Bauteil bzw. jede Baugruppe weist hierbei eine eindeutige Materialnummer 
(Dokumentennummer, respektive Teilenummer) auf. Bei Gleichteilen (Instanzen) ist die 
Teilenummer gleich, der Instancename (Instanzname) ändert sich aber zur eindeutigen 
Kennzeichnung des Bauteils bzw. der Baugruppe. 
 
Alle Beziehungen die CATIA V5 (bzw. der Anwender) während des Produktentwicklungsprozesses 
anlegt, werden im Specification tree (Konstruktionsbaum) gespeichert. 
 

 
Abb.  1: Strukturbaum eines *.CATProduct 

 
Jede Baugruppe, jedes Bauteil und jede Zeichnung wird hierbei als eigenständiges Dokument 
gesehen. Components (Komponenten) werden in dieser Ausführung nicht betrachtet, da diese 
nur Gliederungsebenen darstellen und somit kein direkter Zusammenhang zwischen den 
Komponenten und dem Link Management in CATIA V5 besteht. 
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3. Relational Design und Link Management 

Ein Link (respektive Dateiverknüpfung) ist ein Verweis auf eine Datei oder ein Verzeichnis im 
Dateisystem eines Computers. Sie dient dazu, von beliebig vielen Stellen aus auf eine, nur einmal 
vorhandene Datei zu referenzieren. [Zitat WIKIPEDIA: Dateiverknüpfung] 
 
In CATIA V5 werden Verknüpfungen zwischen internen und externen Dokumenten verwendet. 
Programminterne Verknüpfungen sind Verknüpfungen zwischen Baugruppen, Bauteilen, 
Zeichnungen oder anderen nativen Dateitypen. Programmexterne Verknüpfungen sind 
Verknüpfungen zu externen Dateitypen die für den Produktentwicklungsprozess relevant sind 
(z.B. Konstruktionstabellen aus MS Excel, Bilddateien für Materialien, etc.). 
 

3.1. Einteilung von internen Verknüpfungen 

3.1.1. Product Structure Links 

Als Product Structure Links (Strukturlinks) werden Verknüpfungen zwischen Baugruppen 
und deren Kindern (auch Unterbaugruppen) bezeichnet. Hier wird zwischen nativen 
CATIA V5 Dateien (Instance-Links) und nicht nativen CATIA V5 Dateien (Shape-Links), z.B. 
*.model, *.wrl, *.cgr, unterschieden. Die Aufgabe der Product Structure Links ist die 
Organisation eines logischen Abbildes eines realen Produkts. Alle Product Structure 
Links werden innerhalb eines Produkt-Dokumentes (*.CATProduct) gespeichert und 
verwaltet. 
 
 
 
 

  

Abb.  2: Product Structure Links 

http://de.wikipedia.org/wiki/Dateiverkn%C3%BCpfung
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3.1.2. Assembly Design Links 

Als Assembly Design Links werden Verknüpfungen bezeichnet die entweder im 
Baugruppenkontext erstellt wurden (Contextual-Links) oder Randbedingungen zur 
Positionierung von Bauteilen und Unterbaugruppen darstellen (Constaints). 
 
Die Contextual-Links (auch Context-Links) können mit Hilfe von zwei unterschiedlichen 
Methoden erzeugt werden. 
 
Copy -> Paste Spezial -> As Result with Link 

Bei dieser Methode wird durch das Kopieren und Einfügen eines Objekts innerhalb eines 
Baugruppenkontextes (also innerhalb eines *.CATProduct) eine Verknüpfung erzeugt. 
Hierbei wird beim Einfügen die Funktion Paste spezial -> As Result with Link genutzt um 
eine Beziehung zwischen dem Kopiertem und dem Ursprungsobjekt zu erzeugen. 
 
Skelett-Methode 

Bei der Skelett-Methode wird eine Geometrie die sich innerhalb eines Bauteils befindet 
in einem anderen Bauteil weiterverwendet (Baugruppenkontext). Hierbei legt CATIA 
automatisch ein neues geometrisches Set an („external References“). 
 
Bei beiden Methoden werden Import-Links erzeugt. Import-Links können in die 
Übergruppe Contextual Links eingegliedert werden. 
 
In CATIA V5 existieren Möglichkeiten Objekte zu publizieren (Publication). Hierbei wird 
ein internes Objekt (existiert nur in einem Bauteil bzw. einer Baugruppe) nach außen, 
mit einem eindeutigen Namen sichtbar gemacht. Die veröffentlichten Objekte basieren 
im Gegensatz zu nicht veröffentlichten Objekten nicht auf der UUID (Unique Universal 
Identifier), sondern auf dem Name (mit Instancename des Root-Objekts) des 
veröffentlichten Objekts. Objekte können so einfacher ausgetauscht werden. 
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3.1.3. Referenz-Links (CCP-Links) 

CCP-Links (Cut-Copy-Paste-Links) entstehen durch Wiederverwendung (Copy -> Paste 
spezial -> As Result with Link) von Objekten außerhalb einer Produktstruktur. D.h. die 
beiden Bauteile zwischen denen ein Objekt mit Hilfe eines CCP-Links verknüpft werden 
soll, müssen beide als einzelne Datei (also eigenes Fenster) in CATIA V5 geöffnet sein. 
 
Des Weiteren werden bei der Erstellung von Zeichnungen (*.CATDrawing) sowie beim 
Referenzieren auf externe Dateiformate (z.B. *.xls bei der Erstellung einer 
Konstruktionstabelle (Design Table)) Referenz-Links erzeugt. 

3.2. Unterschied Import-Links zu Referenz-Link 

Import-Links als auch Referenz-Links können beide mit der Funktion Copy -> Paste spezial 
-> As Result with Link erstellt werden. Der Unterscheid zwischen den Link Typen ist, dass 
Import-Links (Assembly Design Links) innerhalb eines übergeordneten Kontextes erstellt 
werden (diese Art von Links werden immer innerhalb eines *.CATProduct erstellt). Durch 
den übergeordneten Kontext bleiben die Positionen der kopierten und eingefügten 
Objekte erhalten. D.h. ein kopierter Körper der im Baugruppenkontext eingefügt wurde 
kann seine Lage (Position im 3 dimensionalen Raum) nicht ändern da das Ursprungsobjekt 
seine Position festlegt und durch den Kontext eindeutig in Lage und Position bestimmt ist. 
Bei Referenz-Links gibt es keinen übergeordneten Kontext der diese Lage bzw. Position 
eindeutig definiert. Der kopierte und eingefügte Körper kann somit frei im Raum 
verschoben und ggf. positioniert werden. 
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3.3. Analyse von Verknüpfungen 

Verknüpfungen (Links) können durch den Anwender eingesehen, analysiert und bei Bedarf 
angepasst, d.h. geändert, werden. Im Gliederungspunkt 3.1 (Einteilung von internen 
Verknüpfungen) wurden die theoretischen Grundlagen der internen CATIA V5 Links 
erläutert. Diese müssen vom Anwender beim Umstrukturieren von Links beachtet werden 
da nur gleichartige Linktypen ersetzt, bzw. geändert werden können. 

3.3.1. Der Desk (Schreibtisch) 

Der Desk (Schreibtisch) zeigt die Verknüpfungen aller in der Session (Sitzung) 
verfügbaren Dokumente, sowie deren Status, an. Hierbei werden sowohl die 
Verknüpfungen als auch die logischen Beziehungen der Verknüpfungen visualisiert. 
 
 
 

 
 

 
Der Desk wird automatisch aktualisiert sobald Verknüpfungen in den geladenen 
Dokumenten aktualisiert, geändert bzw. gelöscht werden. 
Die farblichen Hintergründe zeigen den jeweiligen Status des Dokuments an und dienen 
zur schnellen Bearbeitung von Links. 
 
FARBE BEDEUTUNG 

Weiß 
Das Dokument ist in der Sitzung geladen. Der Link ist hergestellt 
und aktualisiert. 

Schwarz 
Das Dokument ist nicht geladen. Es ist nicht sichergestellt, dass der 
Link aktualisiert ist, d.h. ob Änderungen am Quellobjekt 
durchgeführt wurden, die noch nicht aktualisiert sind. 

Rot 
Das Dokument wurde nicht gefunden. Die Datei wurde entweder 
mit dem Windows-Explorer verschoben oder außerhalb von CATIA 
umbenannt. 

Tabelle 1: Farbcode Schreibtisch 

 
Je nach Dokumentenstatus stehen weitere Funktionen im Kontextmenü zur Verfügung. 
Über die Properties (RMT -> Eigenschaften) kann der Dateiname, Dateipfad, Dateigröße, 
Änderungszeitpunkt, sowie die Lese- und Schreibrechte der Datei abgefragt werden. Bei 
geladenen, also weiß markierten Dokumenten, können des Weiteren die 
Verknüpfungen explizit ausgewertet, sowie der CATDUA (internes 

Abb.  3: Desk (Schreibtisch) 
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Datenqualitätsprüftool von CATIA V5) aus dem Kontext aufgerufen werden. Geladene 
Dokumente können direkt vom Schreibtisch aus öffnen werden. Werden geladene 
Dokumente in der Session nicht mehr benötigt können diese über das Kontextmenü 
entladen (RMT -> unload) werden. Hierbei wird die Datei aus dem Arbeitsspeichern 
gelöscht (keine physikalische Löschung sondern nur die Löschung des reservierten 
Platzes im Arbeitsspeicher). 

 
Schwarz markierte Dateien können nachgeladen bzw. geöffnet werden. Beim Nachladen 
(RMT -> Load) werden die Dateien in den Arbeitsspeichern geladen und durch CATIA 
untersucht (nur gelesen). Beim Öffnen (RMT -> Open) werden die Dateien zuerst in den 
Arbeitsspeicher geladen und anschließend geöffnet. Dies kann bei großen Dateien zu 
langen Ladezeiten führen. 

 
Rot markiert Dokumente wurde außerhalb von CATIA physikalisch verschoben, gelöscht 
oder umbenannt. CATIA sucht nun die Datei anhand deren, im Produkt-Dokument 
gespeicherten Dateinamen sowie Dateipfad. Werden die Dateien nicht automatisch 
gefunden können sie über das Kontextmenü (RMT-> Find) durch den Anwender manuell 
selektiert werden. Die manuell selektierten Dateien werden im Anschluss direkt 
geladen. 

 

3.3.2. Laden, synchronisieren, isolieren, ändern von 

Verknüpfungen 

Wie bereits im Gliederungspunkt 3.3.1 (Der Desk (Schreibtisch)) erläutern können bei 
geladenen Dokumenten die Verknüpfungen explizit bearbeitet werden. Hierfür stehen 
dem Anwender folgende Funktionen zur Verfügung: 
 
 

  

Abb.  4: Bearbeiten von Verknüpfungen 
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Load (Dokument laden) 

Existiert eine Verknüpfung zu einem Dokument welches nicht in der Sitzung geladen ist, 
so kann dieses über die Schaltfläche (Load) geladen werden. Alle Verknüpfungen die auf 
dieses Dokument zeigen werden im Anschluss automatisch synchronisiert. 

Synchronize (Synchronisieren) 

Die Schaltfläche Synchronisieren (Synchonize) synchronisiert (von griechisch συν (sýn), 
„zusammen“ und χρόνος (chrónos), „Zeit“, wörtlich etwa „Herstellen von Gleichlauf“) 
die Verknüpfungen eines Dokumentes. Dies ist notwendig sobald das Quellobjekt 
geändert wurde, die Verknüpfungen aber noch nicht aktualisiert sind. 

Activate / Deactivate (Aktivieren / Deaktivieren) 

Eine Verknüpfung kann aktiviert bzw. deaktiviert werden. Deaktivierte Verknüpfungen 
werden nicht aktualisiert. Beim Öffnen des Ziel-Dokuments (Dokument in das ein 
kopiertes Objekt mit Verknüpfung eingefügt wurde) wird das Quelldokument nicht 
automatisch geladen. 

Isolate (Isolieren) 

Die ausgewählte Verknüpfung wird isoliert, d.h. vollständig unterbrochen. Eine Isolation 
einer Verknüpfung ruft das kontextuelle Aufheben einer Beziehung hervor. Es wird eine 
explizite Geometrie ohne Assoziativität erzeugt die nicht geändert werden kann. 
Verknüpfungen werden isoliert sobald die Freigabe von Bauteilen erfolgt. Hierbei ist 
eine Isolation der Verknüpfungen gewünscht um Geometriebeeinflussungen die durch 
nicht freigegebene Bauteile auf das freigegebene Bauteil zu unterbinden. Des Weiteren 
werden Verknüpfungen isoliert sobald diese nicht mehr für den 
Produktentwicklungsprozess benötigt werden. 

Replace (Ersetzen) 

Das Quelldokument der ausgewählten Verknüpfung wird durch ein vom Anwender 
ausgewähltes Quellobjekt ersetzen. Wurden die Verknüpfungen ohne die Verwendung 
von Publications (Publikationen) erzeugt muss die UUID des ursprüngliches 
Quelldokuments mit der des neu ausgewählten Quelldokuments exakt übereinstimmen. 
Ist dies nicht der Fall, wird die Funktion abgebrochen. 

Change Publication (Publikation ändern) 

Würde die Verknüpfung mit Hilfe einer Publication (Publikation) durch den Anwender 
erstellt, so kann durch klicken der Schaltfläche diese Publikation durch eine andere 
ersetzt werden. Die UUID des neuen Quelldokuments muss nicht mit der des 
ursprünglichen Quelldokumentes übereinstimmen da die Verknüpfung nicht auf der 
UUID sondern auf einem eindeutig definierten Namen basiert. Die Auswahl der neuen 
Publikation erfolgt über die Selektion einer Publikation innerhalb des Specification tree 
(Konstruktionsbaums) 
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4. CATIA Einstellungen zur Lokalisierung von 
Dokumenten 

Die Einstellung, wie Dokumente durch CATIA V5 lokalisiert werden, ist ein essentielle Einstellung 
für das weitere Arbeiten mit Verknüpfungen. 
Die Einstellungen (Settings) die hierzu getroffen werden können befinden sich unter folgendem 
Einstellungspfad: 
 
Tools -> Options -> General -> Document (Tools -> Optionen ->  Allgemein -> Dokument) 
 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

  

Abb.  5: Einstellungen für die Dokument-Lokalisierung 
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Document Environments (Dokumentenumgebung) 

Die Einstellungen innerhalb der Dokumentenumgebung (Document Environment) legen fest in 
welcher Ordnerstruktur die verknüpften Dokumente durch CATIA gesucht werden. Die 
Einstellung Folder (Ordner) legt fest, dass Dokumente im gesamten Arbeitsplatz, ohne 
Einschränkungen, gesucht werden. 

Die eingeschränkte Suche wird mit Hilfe von logischen Dateipfaden, die sogenannten DLNames 
(DLNamen), erreicht. Hierbei wird durch die DLNamen festgelegt innerhalb welcher Dateipfade 
CATIA die Verknüpfungen sucht. 

Die weiteren Einstellmöglichkeiten werden in dieser Ausführung nicht näher erläutert. 

Linked Document Localisation (Lokalisierung verknüpfter Dokumente) 

Die Einstellungen innerhalb des Abschnittes Lokalisierung verknüpfter Dokumente legt die 
interne Suchreihenfolge zum Lokalisieren verknüpfter Dokumente fest. Wird CATIA als 
Produktivsystem eingesetzt weisen Dokumente eine hohe Anzahl von Verknüpfungen auf die 
durch ein externes Datenmanagement geordnet werden (Windows Dateiebene). Dies bedeutet, 
dass sich innerhalb von CATIA Dokumenten eine Vielzahl von Verknüpfungen zu 
unterschiedlichen Dateien aus unterschiedlichen Dateipfaden befinden. Diese wechseln durch 
Versionierung, Umstrukturierung etc. den physikalischen Speicherpfad. CATIA versucht beim 
Laden bzw. Öffnen von Dateien alle Verknüpfungen zu synchronisieren. Hierzu müssen auch 
verschobene Dokumente lokalisiert und geladen werden. 

Die Liste stellt eine abstrakte Art des Rankings dar. Sie wird von CATIA von oben nach unten 
durchlaufen. Je höher ein Eintrag in der Liste geführt wird desto höher ist die Suchpriorität durch 
CATIA. 

Folgendes Beispiel zeigt wie CATIA bei den unterschiedlichen Einstellungen versucht die 
verknüpften Dokumente zu finden. 

Es wird ein Projektordner auf der Partition D:\ der lokalen Festplatte angelegt. Innerhalb diese 
Ordner befindet sich ein natives CATIA Baugruppendokument (*.CATProduct). Des Weiteren 
befindet sich innerhalb dieses Projektordners ein Unterordner (Name: „Bauteile“). In diesem 
Ordner befindet sich ein einzelnes natives CATIA Bauteil (*.CATPart). 
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*.CATProduct Bauteile
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E:\
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Abb.  6: Beispiel Lokalisierung verknüpfter Dokumente 
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1. Folder of the link (Ordner der Verknüpfung) 
Das Dokument wird innerhalb des Pfades der Verknüpfung gesucht (D:\Projekt_1\Bauteile) 

2. Folder of pointed document (Ordner des angezeigten Dokuments) 
Das Dokument wird im selben Pfad wie das zu öffnende Dokument gesucht (E:\Projekt_2) 

3. Relative folder (Relativer Ordner) 
Das Dokument wird in allen Unterordner des Pfades, aus dem der Hauptdokument geöffnet 
wurde, gesucht (E:\Projekt_2\Bauteile) 

4. Other folder (Andere Ordner) 
Das Dokument wird in einem vom Anwender explizit vorgegebenen Pfad (es können auch 
mehrere Suchpfade angegeben werden) gesucht (E:\Projekt_3) 

 
Alle weiteren Einstellmöglichkeiten werden in dieser Ausführung nicht behandelt. 
 
ANMERKUNG: 
Die Einstellungen sollten durch einen Administrator in einer globalen Firmenumgebung (bzw. 
OEM-Umgebung) festgelegt und nicht durch einzelnen Anwender angepasst werden. Die präzise 
Einstellung der Lokalisierungsfunktion bringt einen signifikanten Performancevorteil beim 
Arbeiten mit CATIA V5 und sollte bei der Administration stets beachtet werden! 

5. Die UUID (Universal Unique IDentifier) 

UUID ist die Abkürzung für Universal Unique Identifier. Die UUID wird für jedes Dokument 
automatisch erstellt in den Dateiquelltext aufgenommen. Sie ermöglicht durch ihre 
Einzigartigkeit eine eindeutige Kennzeichnung des Dokumentes. Die UUID setzt sich aus 
folgenden Informationen zusammen: 

 Hardwareinformationen des Systems auf dem die Datei erzeugt wurde (Target-ID) 
 Zufallszahl (Gewährleistung der Eindeutigkeit) 
 Zeitpunkt (Uhrzeit + Datum) der Dateierstellung 
 Zeitpunkt (Uhrzeit + Datum) der Dateiänderung 

Der letzte Aufzählungspunkt wird während der Konstruktion durch Speicherung des Dokumentes 
geändert. 

Die UUID jedes CATIA V5 Dokumentes ist exakt 128 Bit lang. Sie kann, außer von Dássault 
Systems, weder ausgelesen noch geändert werden. Durch die CAA Schnittstelle (interne CATIA 
Programmierschnittstelle auf C++ Basis)  haben Programmieren lesenden Zugriff auf die UUID 
(z.B. in SmarTeam). 
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5.1. Verwendung der UUID 

Wie bereits im letzen Gliederungsabschnitt 5 (Die UUID) erläutert, kann die UUID, außer 
durch DSS selbst oder durch ein CAA-Programm, vom Anwender nicht ausgelesen oder 
geändert werden. Die UUID wird von CATIA V5 ausschließlich zur internen Verwaltung von 
Verknüpfungen benötigt. 

Externe Links (z.B. Instance-Links bzw. Import-Links) zwischen Modellen können mit Hilfe der 
UUID durch CATIA sehr einfach verwaltet werden. Erst dadurch ist es möglich die 
Verknüpfungen zwischen CATIA Dokumenten zu synchronisieren. 

Bei der Synchronisation werden CATIA-intern folgende zwei Prüfroutinen durchlaufen: 

1. Abfrage ob die Referenz (Quelldatei) geladen ist. Nur dann kann das Zieldokument 
synchronisiert (upgedated) werden 

2. Abfrage ob die Referenz geändert wurde. Hierzu ist der Zeitpunkt der Dateiänderung 
aus der UUID notwendig 

 

5.2. Änderung der UUID 

Während eines Produktentwicklungsprozesses kann es zu der Situation kommen das die 
UUID eines Dokumentes geändert werden muss. Dies ist der Fall sobald ein Bauteil mit einer 
Fit, Form, Function Änderung unterliegt. 

Bei einer Fit-Form-Function Änderung (auch als F3 Änderung bekannt) ändert sich, im 
Gegensatz zu einer Versionierung bzw. Revision (UUID bleibt in diesen Fällen gleich), die 
komplette Gestallt (es muss ein neues Betriebsmittel (Werkzeug) konstruiert werden), die 
Größe (das Bauteil kann nicht mehr in das ursprüngliche Produkt eingebaut werden) oder 
die Funktion (in Bezug auf die Funktion für die das Bauteil entwickelt wurde).  

Da die UUID nicht manuell durch den Anwender geändert werden kann, müssen interne 
CATIA Funktionen zum Ändern der UUID eines Dokumentes genutzt werden! Nachfolgende 
Tabelle gibt eine Übersicht über diese Funktionen. 
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Liste aller Funktion die eine neue UUID erzeugen 

CATIA FUNKTION BESCHREIBUNG 

File -> New 
Es wird ein neues CATIA-Dokument erzeugt. Dieses hat eine 

neue UUID 

File -> New from 

Es wird ein neues CATIA-Dokument aus einem bereits 

existierenden CATIA-Dokument erzeugt. Hierbei werden alle 

Verknüpfungen des Dokuments aufgelistet. Der Anwender 

kann explizit, verknüpfte Dokumente auswählen die ebenfalls 

eine neue UUID erhalten sollen (FIT-FORM-FUNCTION 

Änderung) 

File -> Save as (in 

Verbindung mit Schalter 

„Save as new document“ 

Der Schalter „Als neues Dokument speichern“ muss hierbei 

aktiviert sein. CATIA speichert das aktuelle Dokument mit 

einer neuen UUID ab. Verknüpfte Dokumente behalten ihre 

UUID 

Insert new Product 

Wird die Funktion (Assembly Design) genutzt wird ein 

komplett neues Baugruppen-Dokument mit neuer UUID 

erzeugt und in das aktive Baugruppen-Dokument eingefügt 

Insert New Part 

Wird die Funktion (Assembly Design) genutzt, wir ein 

komplett neues Bauteil mit neuer UUID erzeugt und in das 

aktive Baugruppen-Dokument eingefügt 

Document Template 

Creation 

Es wird ein komplett neues Dokument aus einer 

Dokumentenvorlage erzeugt. Dieses Dokument besitzt eine 

eigene UUID 
Tabelle 2: Funktionen die neue UUID erzeugen 
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Liste der Funktionen bei denen die UUID gleich bleibt 

CATIA FUNKTION BESCHREIBUNG 

File -> Save 

Das aktive Dokument wird mit derselben UUID gespeichert. 

Existieren Verknüpfungen werden die verknüpften 

Dokumente ebenfalls mit der ursprünglichen UUID 

gespeichert 

File -> Save as 

Das aktive Dokument wird unter einem neuen Dateinamen 

(ggf. neuer Dateipfad) aber der ursprünglichen UUID 

gespeichert. Diese Funktion kann bei Versionierungen und 

Revisionen eingesetzt werden 

File -> Save All 
Alle in der Sitzung verfügbaren Dokumente werden mit ihren 

ursprünglichen UUID´s gespeichert 

File -> Save Management Siehe File -> Save bzw. File -> Save as 

File -> Send to (Directory) 

Alle verknüpften Dokumente und das ausgewählte Dokument 

selbst werden mit den ursprünglichen UUID´s in einen neuen 

Ordner kopiert 

Tabelle 3: Funktionen die UUID nicht ändern 

 

6. CATIA Speichermethoden 

Wie bereits im vorherigen Gliederungspunkt erläutert, ist es wichtig mit welcher Operation 
Daten in CATIA gespeichert werden. Die Änderung einer UUID durch Speichern ist ein 
irreversibler Vorgang und hat Auswirkung auf die gesamte Konstruktion. Im folgenden Abschnitt 
werden die einzelnen Möglichkeiten der Datensicherung unter CATIA einzeln beschreiben. 

6.1. Datei -> Speichern 

Datei -> Speichern (File -> Save) speichert das aktuell aktive CATIA Dokument. Alle 
verknüpften Dokumente werden bei Änderungen welche die verknüpften Dokumente 
betrifft automatisch mitgespeichert. Da dieses Verhalten nicht zwingend durch den 
Anwender gewünscht wird gibt CATIA eine Warnmeldung aus. Innerhalb dieser wird auf das 
Save Management Tool verwiesen. Beim Speichern mit Hilfe dieser Funktion wird die UUID 
des gespeicherten Dokumentes nicht geändert. 
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6.2. Datei -> Speichern als 

Datei -> Speichern als (File -> Save as) speichert das aktuell aktive CATIA Document unter 
einem neuen Dateinamen bzw. unter einem neuen Dateipfad ab. Durch Aktivierung des 
Schalters „Als neues Dokument speichern“ (Save as new document) wird eine neue UUID das 
gespeicherten Dokumentes erzeugt. 
Das Speichern eines Dokumentes unter einem neuen Dateinamen bzw. unter einem neuen 
Dateipfad fordert, dass alle zu ihm in Beziehung stehenden Dokumente ebenfalls gespeichert 
werden. 
CATIA gibt aufgrund dieses Verhaltens eine Warnmeldung aus. Diese besagt das mehrerer 
Dokumente zusätzlich mitgespeichert werden und verweist explizit auf das Save 
Management Tool. 

6.3. Datei -> Alle sichern 

Datei -> Alle sichern (File -> Save all) ist eine schnelle Möglichkeit, unter Beibehaltung aller 
ursprünglichen UUID´s, alle geöffneten Dokumente einer Sitzung zu speichern. Gibt es 
Dokumente in der Sitzung, die während dieser neu angelegt wurden bzw. auf die nur ein 
Leserecht existiert, wird eine Warnmeldung ausgegeben. 
Wird diese Meldung mit OK bestätigt, wird ein neues Dialogfenster geöffnet in das für alle 
nicht gespeichert Dokumente ein neuer Dateiname sowie ein Dateipfad angegeben werden 
muss. 

6.4. Datei -> Sicherungsverwaltung 

Die Sicherungsverwaltung (File -> Save Management) bietet eine Abspeicherung für alle in 
der Sitzung geöffneten Dokumente und deren verknüpfte Dokumente an. 
Die Sicherungsverwaltung kann verwendet werden wenn alle Dokumente eines 
Hauptdokumentes, unter Anpassung der Verknüpfungen untereinander, in ein neues 
Verzeichnis kopiert werden sollen. Des Weiteren bietet es dem Anwender die Möglichkeit 
den Speicherstatus der geladenen Dokumente einzusehen. 
Die Speicherung der Dokumente erfolgt erst nach Bestätigung der Dialogbox mit OK. Im 
folgenden Abschnitt erhalten Sie eine detaillierte Beschreibung der Dialogbox und deren 
Funktionen. 
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Sicherungsverwaltung Dialogbox 

 
NUMMER SPLATENNAME BEDEUTUNG 

1 State 

Gibt den Speicherstatus des Dokumentes an 

Modified 
Das Dokument wurde in der Sitzung modifiziert 
und muss gespeichert werden 

Open 
Das Dokument ist geöffnet wurde aber in der 
Sitzung nicht modifiziert. Es ist kein Eingriff 
erforderlich 

New 
Das Dokument wurde innerhalb der Sitzung 
neu erzeugt und muss gespeichert werden 

Modified by 
synchronisation 

Das Dokument wurde von einer anderen CATIA 
Sitzung modifiziert. D.h. es gibt eine zweite 
CATIA Instanz die diese Datei modifiziert hat. 
Die erste CATIA Instanz versucht zu speichern 
und erhält dabei den Status. 

Read Only 

Das Dokument wurde geändert ist aber nur im 
Lesezugriff verfügbar. Um die Änderungen zu 
speichern muss ein neuer Dateiname bzw. ein 
neuer Dateipfad ausgewählt werden 

2 Name 
Dokumentenname (Dateiname) des Dokumentes. Unter diesem 
Dateinamen wird die Datei physikalisch gespeichert 

3 Location Dateipfad unter dem das Dokument gespeichert wird 

4 Action 

Aktion die nach dem Bestätigen der Dialogbox durch CATIA 
ausgeführt wird 

„leer“ Es wird keine Aktion ausgeführt 

Save Das Dokument wird gespeichert 

Auto Save 
Das Dokument wird automatisch gespeichert 
da ein übergeordnetes, mit ihm in Beziehung 
stehendes Dokument gespeichert wurde  

5 Access 
Gibt eine Information über die Schreib- und Leserechte des 
Dokumentes zurück 

6  Unsaved File(s) Zeigt die Anzahl der noch nicht gespeicherten Dokumente an. 

Abb.  7: Dialogbox Sicherungsverwaltung 

1 2 3 4 5 

6 7 8 
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Diese können identifiziert werden indem die Spalten State 
(=Modified) sowie Action (=“leer“) durch den Anwender 
ausgewertet werden 

7  Pattern Name 
Mit Hilfe dieser Funktion kann dem zu speichernden Dokument 
ein Präfix- bzw. Suffix im Dateinamen angehängt werden. Der 
Stern (*) steht hierbei als Wildcard für den Dateinamen 

8 Independent Save 

Die Funktion ermöglicht das unabhängige Speichern von 
Dokumenten die in Beziehung miteinander stehen. ACHTUNG: 
Möglicherweise werden Dokumente die in Beziehung stehen 
nicht explizit gespeichert. Die Beziehungen verlierern somit die 
Gültigkeit und müssen nach dem erneuten Öffnen der 
Dokumente vom Anwender neu gesetzt werden 

Tabelle 4: Übersicht Dialogbox Sicherungsverwaltung 

Sicherungsverwaltung Schaltflächen 

SCHLATFLÄCHENNAME BEDEUTUNG 

Save 
Markiert das Ausgewählte Dokument zur Speicherung. Diese 
Schaltfläche ist nur bei Dokumenten aktive die bereits physikalisch 
existieren (d.h. bereits gespeichert wurden) 

Save As 

Markiert das ausgewählte Dokument zur Speicherung. Die Eingabe 
eines Dateinamens sowie Dateipfades ist erforderlich. Es können in der 
Sitzung neu angelegt Dokumente aber auch bereits existierende 
Dokumente gespeichert werden 

 Propagate directory 

Markiert alle Dokumente die in Beziehung zum ausgewählten 
Dokument stehen zur Speicherung. Alle in Beziehung stehenden 
Dokumente werden in denselben Dateipfad gespeichert wie das 
ausgewählte Dokument. Diese Schaltfläche steht nur bei Dokumenten 
zur Verfügung die Beziehungen aufweisen (z.B. bei Baugruppen) 

Reset 

Setzt die bereits vom Anwender getätigten Aktionen (Save, Save As, 
Pattern Name) für das ausgewählte Dokument zurück. Die in Beziehung 
stehen Dokumente werden, außer bei der Funktion „Propagate 
directory“, ebenfalls zurückgesetzt 

Tabelle 5: Schaltflächen Sicherungsverwaltung 
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6.5. Datensicherung mit CATIA V5 

Konstruktionsdaten müssen während eines Produktentwicklungsprozesses oft 
„umgespeichert“ werden. Hierbei sollen alle Daten eines Projektes an einen anderen, 
beliebigen, physikalischen Ort transformiert werden, ohne den Verlust der internen 
Beziehungen. 

Der folgende Abschnitt beschreibt zwei Methoden zur Datensicherung eines kompletten 
Projektes. 

Save Management -> Propagate Directory 

 Öffnen des Hauptproduktes (bzw. Hauptzeichnung) mit dem alle Dokumente des 
Projektes in Beziehung stehen 

 File -> Save Management 
 Auswahl des Hauptproduktes (bzw. Hauptzeichnung) aus der Liste 
 Save Management -> Save As: Neuen Dateipfad und ggf. neuen Dateinamen des 

Projektes eingeben 
 Save Management -> Propagate directory (bei ausgewähltem Hauptprodukt (bzw. 

Hauptzeichnung)) 
 Save Management mit OK abschließen 

Alle Dateien werden nach Bestätigung des Save Managements in den ausgewählten 
Ordner des Hauptproduktes gespeichert.  

Send to -> Directory 

 Öffnen des Hauptproduktes (bzw. Hauptzeichnung) mit dem alle Dokumente des 
Projekt in Beziehung stehen (nicht zwingend erforderlich. Funktion kann auch ohne 
geöffnetes Dokument ausgeführt werden) 

 File -> Send To -> Directory 
 Auswahl aller Dokumente die mit dem Hauptprodukt (bzw. Hauptzeichnung) in 

Beziehung stehen (siehe Abb.  8: Send-To Dialogbox) 
 Send To mit OK bestätigen 

Nach Abschluss des Send To Befehls werden alle ausgewählten Dateien in das 
ausgewählte Verzeichnis kopiert. Hierbei werden die Dateien geöffnet (intern, d.h. nicht 
vom Anwender sichtbar). Dieser interne Vorgang ist notwendig da CATIA die 
Beziehungen der Dokumente neu speichern muss. 

  



 

 Seite 21 von 24 DANIEL FRAUENRATH 

Unterschied Save Management / Send To 

Der Unterschied zwischen der Save Management Methode zur Send To Methode ist, 
dass bei der Send To Methode alle, in Beziehungen stehenden Dokumente (egal um 
welchen internen Verlinkung typ es sich handelt (Shape, Import, Referenz), kopiert 
werden. Das Save Management speichert nur erweiterte native CATIA Dateien (also 
auch *.models) in den neuen Ordner ab. Werden Shape-Verlinkungen auf externe 
Dateiformate (z.B. *.cgr, *.wrl, etc.) identifiziert, so werden diese nicht in den neuen 
Dateipfad gespeichert. Es wird lediglich die Verknüpfung (der Link) des 
Hauptdokumentes geändert. 

Dieses Verhalten ist vor allem beim Datenaustausch über Wechselmedien (z.B. USB-
Sticks, etc.) bzw. beim Datenaustausch auf Serverebene nicht gewünscht. Der Anwender 
welcher die gesicherten Daten weiterverarbeiten soll, hat eventuell keinen Zugriff auf 
die ursprünglichen Datenverzeichnisse und erhält beim Öffnen Fehlermeldungen. Die 
nicht gesicherten Dateien sind nicht mehr für diesen Anwender zugänglich und müssen 
ggf. nachgesendet werden. 

In der Praxis hat sich durch diesen Nachteil des Save Managements der Methode Send 
To durchgesetzt und wird heute von allen OEM beim Datenversand sowie bei der 
Datensicherung eingesetzt. Die Funktionen der Send To Methode werden im 
Gliederungsabschnitt 6.6 (Die Send-To Funktion) näher erläutert 
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6.6. Die Send-To Funktion 

Wie bereits im Gliederungsabschnitt 6.5 (Datensicherung mit CATIA V5) erläutert wird die 
Send To Methode in der Praxis zum Datenaustausch sowie zur Datensicherung mit CATIA V5 
eingesetzt. Nachfolgend werden die Funktionen dieser Methode erläutert. 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

  

Abb.  8: Send-To Dialogbox 
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4 
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NR. NAME BEDEUTUNG 

1 Can be copied 

Liste aller in Beziehung stehenden Dokumente zum 
vom Anwender ausgewählten Hauptdokument (das 
Hauptdokument selber befindet sich auch in dieser 
Liste) 

2 Will be copied 
Liste alle Dokumente die nach der Bestätigung des 
Dialoges kopiert werden 

3 -- 

Schaltflächen zum verschieben der Dokumente 
zwischen den Felder „Can be copied“ und „Will be 
copied“. Die erste bzw. dritte Schaltfläche verschiebt 
alle Dokumente zwischen den Feldern. Die zweite 
und vierte Schaltfläche verschiebt die ausgewählten 
Dokumente zwischen den Feldern 

4 Copy to / Browse 
Angabe des Pfades in den die Dateien kopiert 
werden. Mit Hilfe der „Browse“ Schaltfläche kann der 
Pfad im Explorer selektiert werden 

5 Keep Directory Structure 

Falls die ursprünglichen Dokumente in einer 
Ordnerstruktur gespeichert waren, kann diese 
übernommen werden. D.h. es werden nicht nur die 
einzelnen Datei in einen Ordner kopiert sondern alle 
vorhandenen Unterordnern mitsamt den 
Dokumenten 

6 Rename Target 
Die kopierte Datei wird unter einem neuen Namen 
abgespeichert. Dies kann mit allen zu kopierenden 
Dokumenten einzeln durchgeführt werden. 

Tabelle 6: Funktionen Send-To Befehl 
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