Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  Inventor
  Zeichnungsaktualisierung hakt, Bug?

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
  
Gut zu wissen: Inventor besser verstehen - Fläche löschen
Autor Thema:   Zeichnungsaktualisierung hakt, Bug? (1030 mal gelesen)
bjrnx
Mitglied
Maschinenbauingenieur


Sehen Sie sich das Profil von bjrnx an!   Senden Sie eine Private Message an bjrnx  Schreiben Sie einen Gästebucheintrag für bjrnx

Beiträge: 21
Registriert: 18.05.2006

erstellt am: 20. Mai. 2015 15:32    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


TestBG.zip

 
Hallo Gemeinde,

im Inventor 2015 ist uns heute aufgefallen, dass eine idw mit Darstellung einer Baugruppe, welche wiederum eine adaptive Unterbaugruppe enthält, keine Aktualisierung der Ansicht stattfindet, wenn die adaptive Baugruppe über eine Abhängigkeit in der Oberbaugruppe getrieben geändert wird. Im Anhang eine Beispielkonstellation.

- idw öffnen und Bemaßung sichten
- Baugruppe.iam öffnen und d3 ("Passend:1") ändern
- zurück zur idw schauen, ob sich was tut

Habe es mit folgendem probiert:
- original 2015er Templates versucht anstelle unserer Angepassten/Migrierten
- Inventor 2015 SP1 und SP2
- Anwendungsoptionen und Dokumenteinstellungen überprüft, ob  da was aufgeschoben wird, war aber nicht so
- mit/ohne Zwischenspeichern oder sogar Schliessen/Öffnen der Dateien und auch komplett Inventor schliessen/öffen

Immer gleiches Resultat, keine Aktualisierung der Ansicht bezüglich dieser Position/Bemaßung.

Es geht
- wenn in der Baugruppe.iam "Verwalten\Alles neu erstellen" händisch durchgeführt wird.
- auch, wenn das Teil bei unterdrückter Abhängigkeit von Hand Hand woanders hin geschoben wird.
- auch in Inventor 2013...ohne irgendwelche Extrawürste.

Kann das jemand nachvollziehen auf einem anderen Rechner? Ist das ein Bug?
Unschöne Sache, wenn unbewusst Zeichnungen mit falschen Bemaßungen rausgehen.

Grüße
Björn

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

freierfall
Ehrenmitglied V.I.P. h.c.
selbstst. techn. Zeichner



Sehen Sie sich das Profil von freierfall an!   Senden Sie eine Private Message an freierfall  Schreiben Sie einen Gästebucheintrag für freierfall

Beiträge: 10768
Registriert: 30.04.2004

WIN10 64bit, 32GB RAM
IV bis 2021

erstellt am: 20. Mai. 2015 17:21    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für bjrnx 10 Unities + Antwort hilfreich

ja ist bei mir auch so, aber ich glaube ich habe noch kein SP daruf 2015. Habe auch Idee was man sonst machen könnte. Sorry Sascha

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Wolfen1982
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Wolfen1982 an!   Senden Sie eine Private Message an Wolfen1982  Schreiben Sie einen Gästebucheintrag für Wolfen1982

Beiträge: 116
Registriert: 30.03.2011

erstellt am: 20. Mai. 2015 18:59    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für bjrnx 10 Unities + Antwort hilfreich

Hallo Björn,

schau mal nach (ich habe nur IV2013) ob in der Zeichnung die richtige Detailgenauigkeit geladen ist. Ebenso in der Baugruppe vergleichen ob die in der Unterbaugruppe mit gleichen Detailgenauigkeit verbaut ist wie sie abgespeichert ist.

MfG Wolfen

------------------

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

bjrnx
Mitglied
Maschinenbauingenieur


Sehen Sie sich das Profil von bjrnx an!   Senden Sie eine Private Message an bjrnx  Schreiben Sie einen Gästebucheintrag für bjrnx

Beiträge: 21
Registriert: 18.05.2006

Intel Core i7-6700K, 16 GB Ram, nVidia Quadro M4000, Windows 10 Pro x64, AIP 2017, ACAD Mechanical 2017, Vault Professional 2017

erstellt am: 21. Mai. 2015 10:11    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo und danke für's Probieren. Dann ist es also egal ob mit oder ohne SP.
Detailgenauigkeiten spielen wohl keine Rolle, alles auf Hauptansicht, und Änderung tut nichts. Wäre aber auch fatal, wenn aufgrund der Detailgenauigkeiten die Zeichnungsaktualisierung hängt.
BTW: Für reduzierte Darstellung in der idw, soll aus meiner Sicht möglichst auch nur die Ansichtsdefinitionen benutzt werden. Bei Detailgenauigkeiten verschluckt sich Inventor häufig, wenn die dargestellte Baugruppe parallel zur idw offen ist und aber eine andere Detailgenauigkeit aktiviert hat. Dann geht manchmal kein Speichern und nix mehr. Ansichten arbeiten da stabiler, und Ausblenden in untergeordneten gesperrten Anschlussbaugruppen funktioniert auch prima (IMHO besser als Unterdrücken).

Gruß
Björn

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

muellc
Ehrenmitglied V.I.P. h.c.
Inventor Administrator



Sehen Sie sich das Profil von muellc an!   Senden Sie eine Private Message an muellc  Schreiben Sie einen Gästebucheintrag für muellc

Beiträge: 3476
Registriert: 30.11.2006

Inventor 2017.4.12 64 bit
Windows 10 Enterprise 64 bit
3DEXPERIENCE R2016x
--------------------
HP Z-Book 15 G4
32 Gig Ram
NVIDIA Quadro M2200
2x HP E243i

erstellt am: 21. Mai. 2015 10:58    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für bjrnx 10 Unities + Antwort hilfreich

Hallo Björn,

ist die Ansichtsdarstellung Assoziativ gestellt?
Habtz ihr mal die Ansichtsdarstellungen umgeschaltet?
Wir hatte heute auch ein Problem mit nicht aktualisierenden Ansichten. (Ohne das adaptivitäten im Spiel waren)

Von Adaptivitäten würde ich eher abraten, da gibt es mittlerweile schöne optionen mit Inventor, die Stabil funktionieren.


[EDITH sagt]
Hatte dein Beispiel zu spät gesehen.
Hier liegts eher an den Fixierungen.
Wenn du gleiche Teile mehrfach anordnen willst, kommst du mit Komponentenanornungen und etwas Mathe ganz gut zurecht.
Wenn du Unterbaugruppe unbedingt benötigt wird für die Montage, würde ich mir mal die Top-Down Modellierung ansehen mit Multi-body-part für die vereinfachte Darstellung.


------------------
Gruß, Gandhi
"Dem guten Frager ist schon halb geantwortet" - Friedrich Nietzsche

[Diese Nachricht wurde von muellc am 21. Mai. 2015 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

bjrnx
Mitglied
Maschinenbauingenieur


Sehen Sie sich das Profil von bjrnx an!   Senden Sie eine Private Message an bjrnx  Schreiben Sie einen Gästebucheintrag für bjrnx

Beiträge: 21
Registriert: 18.05.2006

erstellt am: 21. Mai. 2015 11:41    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,

und danke für die Bemühungen. Wie geschrieben hab ich genau das gleiche Prozedere mit Inventor 2013 gemacht und da geht es.

Im 2015er:

Ansichten auf Vorgabe und assoziativ oder auf Hauptansicht oder unterschiedliche Detailgenauigkeiten: alles ohne Wirkung.

Bezüglich Komponentenanordnung vs. mehrere Teile manuell platziert oder fixiert / nicht fixiert etc.: irrelevant,  und dazu hab ich ja nur einfache zulässige Inventorfunktionen benutzt (der Anhang ist auch nur ein simples Beispiel, ursprünglich ist es in einer "live" Baugruppe mit viel mehr Gebims aufgetreten. Das Beispiel mit den original Inventor 2015 Vorlagen hab ich gemacht, um zu zeigen, dass keine magischen Einflüsse einer verwurschtelten Baugruppe im Spiel sind ;-)) und BTW: es gibt Leute die machen Anordnungen von Anordnungen von Anordnungen..., da sucht man sich teils nen Wolf was wie zusammenhängt und interessante Wirkungen modelltechnisch kann es auch geben.

Bezüglich Adaptivität: wenn man sensibel mit umgeht, hat es in einigen Situationen Daseinsberechtigung. Wird hier benutzt, um z.B. auf fertigen Stahlbau Kabelwege zu legen, die sich in einer separaten temporär adaptiven Unterbaugruppe (=Stücklisteinhalt) an den Stahlbau anpassen (nur Positionieren), zum Schluss wird die Adaptivität ausgeschaltet, ging bisher gut, auch zeichnungstechnisch. Adaptive Skizzen und Elemente werden hier nicht benutzt. Geht alles größtenteils über hauptsächlich skizzenbasiertes Mastermodelling sehr stabil.

Ich plädiere auf Bug, wenn es bei mehreren das gleiche Resultat liefert und die bisher erwähnten Punkte keinen Einfluss haben und sich der 1:1 Vergleich mit Inventor 2013 so wie geschrieben darstellt. Oder?

EDIT
Auch nochmal auf einem sehr jungfräulichen 32bit Windows 7 Inventor 2015 SP2 probiert, gleiches unschönes Verhalten. Habe einen Bug-Report bei Autodesk gemacht...Prinzip Hoffnung 
EDIT

Gruß
Björn

[Diese Nachricht wurde von bjrnx am 22. Mai. 2015 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz