Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  EPLAN Electric P8
  Anlüsse von neu erstellten Symbolen definieren

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Anlüsse von neu erstellten Symbolen definieren (771 mal gelesen)
THW1701
Mitglied



Sehen Sie sich das Profil von THW1701 an!   Senden Sie eine Private Message an THW1701  Schreiben Sie einen Gästebucheintrag für THW1701

Beiträge: 11
Registriert: 27.04.2018

EPLAN Education Version (64-Bit)
Version: 2.8 HF2

erstellt am: 18. Jan. 2019 11:25    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Symboleigenschaften.JPG


Logik.JPG


Symbol.JPG

 
Hallo Zusammen,

wir nutzen bei uns in der Schule die Eplan Education Version 2.6 (HF4), 64-Bit.
Und gleich mal im vorhinein sorry für so viel Text, aber ich hoffe, dass mein Prolem dadurch nachvollziehbar wird.

In der Schule nutzen wir einige Bauteile, die es weder als Artikel im Data Portal noch als Symbol gibt.
Somit wollen wir für diese eigene Symbole erstellen.
Dafür habe ich auch eine eigene Symbolbibliothek angelegt.

Mein Problem stelle ich mal am Beispiel eines Netzgeleichrichters dar.
Ich erstelle wie folgt ein neues Symbol (siehe auch Bild Symboleigenschaften)
Dienstprogramme --> Stammdaten --> Symbol --> Neu
Variante A
Symbolnummer und Name werden vergeben
Symbolart --> Funkton
Als Funktionsdefinition habe ich folgendes ausgewählt:
Elektrotechnik --> Umfromer, Trafo und Gleichricher --> Gleichrichter --> Gleichrichter, variabel
Anschlüsse: 14 (Logik wie im angefügten Bild definiert)

Soweit so schön.
Nun füge ich einen Gerätekasten ein. Auch kein Problem.

Aber jetzt sollen die Anschlüsse dazu kommen und hier liegt das Problem.
Diese sollen später beim einfügen des Symbols sofort ihr entsprechende Anschlussbezeichnung bekommen.
Wie z.B. wenn man eine Spule einfügt diese sofort die Anschlussbezeichnung A1/A2 bekommt.

Wie im Bild des Symbols zu erkennen ist, habe ich exemplarisch zwei Geräteanschlüsse in mein Symbol eingefügt.
Wenn ich dieses Symbol jetzt in meinen Schaltplan einfüge, sollen diesen beiden Anschlüssen gleich die Bezeichnungen N für Anschluss 1 und L1 für Anschluss 2 erhalten. Und daran scheitere ich.

Normalerweise sollte diese Zuordnung ja über Dienstprogramme --> Stammdaten --> Anschlussbezeichung / -beschreibung einstellbar sein. Da kann ich aber für die oben genannte Funktionsdefinition keine 14 Anschlüsse finden.
Wie kann ich also den von mir eingefügten Anschlüssen eine Beschreibung zuordnen wie z.B. bei der schon erwähnten Spule A1 und A2? Bloß halt bei mir N und L1?

Es würde mich sehr freuen, wenn ihr mir da weiterhelfen könnt.

Vielen Dank schon mal.

Schöne Grüße

Tom


Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ralfm
Ehrenmitglied V.I.P. h.c.
Elektrozeichner



Sehen Sie sich das Profil von ralfm an!   Senden Sie eine Private Message an ralfm  Schreiben Sie einen Gästebucheintrag für ralfm

Beiträge: 4892
Registriert: 21.08.2003

Win XP: WSCAD 4.0 bis 5.5, EPLAN P8 bis 1.9,
EPLAN 5.30 bis 5.70.
Win 7 64bit, irgendein Zweikerner, 32GB: P8.2.0...2.7 + Fluid

erstellt am: 18. Jan. 2019 11:36    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für THW1701 10 Unities + Antwort hilfreich

Moin,
warum muss das mit einem Symbol gemacht werden und nicht mit einem Makro, das ist viel flexibler?

------------------
Grüße
Ralf

--------------

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Shrek77
Mitglied



Sehen Sie sich das Profil von Shrek77 an!   Senden Sie eine Private Message an Shrek77  Schreiben Sie einen Gästebucheintrag für Shrek77

Beiträge: 287
Registriert: 20.06.2005

EPLAN 5.70
Electric P8 2.7
Pro Panel 2.7

erstellt am: 18. Jan. 2019 11:36    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für THW1701 10 Unities + Antwort hilfreich

Hi Tom,

als Tipp...bitte erstellt dafür keine Symbole.
Dies wird in EPLAN mit Makros gelöst.
Zeichne dir dein Geräte mit Geärtekasten, Geräteanschlüsse so wie du es benötigst. Es gibt auch verschiedene optische Darstellungen für einen Geräteanschluss. Schau mal in der Special Symbolbibliothek.

Anschließend kannst du das gezeichnete als Makro speicher, und an deinem Artikel hinterlegen.

Grüße

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

THW1701
Mitglied



Sehen Sie sich das Profil von THW1701 an!   Senden Sie eine Private Message an THW1701  Schreiben Sie einen Gästebucheintrag für THW1701

Beiträge: 11
Registriert: 27.04.2018

EPLAN Education Version (64-Bit)
Version: 2.8 HF2

erstellt am: 18. Jan. 2019 11:40    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,

danke für die schnelle Antwort.
Ich habe keine Problem damit, dass mit einem Makro zu machen.
Bloß da hab ich bis jetzt noch gar keinen Plan, wie man das macht.
Aber ich versuch mich mal.

Schöne Grüße

Tom

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

THW1701
Mitglied



Sehen Sie sich das Profil von THW1701 an!   Senden Sie eine Private Message an THW1701  Schreiben Sie einen Gästebucheintrag für THW1701

Beiträge: 11
Registriert: 27.04.2018

EPLAN Education Version (64-Bit)
Version: 2.8 HF2

erstellt am: 21. Jan. 2019 09:08    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Vorlage_Makro.JPG


Eingefugtes_Macro.JPG

 
Hallo Zusammen,

so, ich hab das jetzt mal mit einem Makro probiert.

Ich hab das Makro Vorlage_Maktro erstellt (siehe Bild) und dann über Bearbeiten --> Fenster/Symbolmakro erstellen als Symbolmakro gespeichert.

Dieses Makro habe ich dann meinem Artikel zugewiesen, den ich erstellt habe.

Wenn ich nun das Gerät einfüge, so sieht es so aus wie im Bild "Eingefügtes_Makro"
Der Name T1 passt. Aber es fehlen die Bezeichnungen der Anschlüsse. Diese heißen nicht mehr N, L1 und TaM.
N und TaM werden gar nicht angezeigt und bei ursprünglich L1 steht dabei "12_Klasse+12_Tuersprechanlage-T1".
Für mich nicht nachvollziehbar warum das bei dem Anschluss dabei steht.
Weil wenn dann müsste doch bei allen Anschlüssen der Text stehen oder bei gar keinem. Ich hätte aber gerne, dass auch bei dem eingefügten immer N, L1 und TaM dabei steht.
Was mach ich falsch? Und vor allen Dingen, wie mach ich es richtig?

Vielen Dank für die Hilfe.

Schöne Grüße

Tom

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

FIMA1
Mitglied



Sehen Sie sich das Profil von FIMA1 an!   Senden Sie eine Private Message an FIMA1  Schreiben Sie einen Gästebucheintrag für FIMA1

Beiträge: 144
Registriert: 05.06.2012

erstellt am: 21. Jan. 2019 09:20    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für THW1701 10 Unities + Antwort hilfreich


21-01-201909-16-58.jpg

 
Moin,

ich vermute das die Geräteanschlüsse beim (Makro) einfügen nummeriert werden... Hacken raus!


Gruß
Jo

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

THW1701
Mitglied



Sehen Sie sich das Profil von THW1701 an!   Senden Sie eine Private Message an THW1701  Schreiben Sie einen Gästebucheintrag für THW1701

Beiträge: 11
Registriert: 27.04.2018

EPLAN Education Version (64-Bit)
Version: 2.8 HF2

erstellt am: 21. Jan. 2019 09:30    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Servus Jo,

danke für die schnelle Antwort.
Aber daran lags nicht.
Hab den Haken rausgemacht und es ist keine Veränderung da.

Schöne Grüße

Tom

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

ralfm
Ehrenmitglied V.I.P. h.c.
Elektrozeichner



Sehen Sie sich das Profil von ralfm an!   Senden Sie eine Private Message an ralfm  Schreiben Sie einen Gästebucheintrag für ralfm

Beiträge: 4892
Registriert: 21.08.2003

Win XP: WSCAD 4.0 bis 5.5, EPLAN P8 bis 1.9,
EPLAN 5.30 bis 5.70.
Win 7 64bit, irgendein Zweikerner, 32GB: P8.2.0...2.7 + Fluid

erstellt am: 21. Jan. 2019 11:39    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für THW1701 10 Unities + Antwort hilfreich

Hallo,
das sieht irgendwie nach einer Struktur aus. Der Kasten hat einen Querverweis "/1.4" gibt es den Kasten dort schon? Was passiert, wenn du dem Kasten z.B. das sagst er ist -T10?
Was steht in den Anzeigeeigenschaften des Anschlusses? RMT auf dem Anschluss, dann Reiter Anzeige. Dort steht sicherlich was von "BMK (vollständig)"

------------------
Grüße
Ralf

--------------

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

FIMA1
Mitglied



Sehen Sie sich das Profil von FIMA1 an!   Senden Sie eine Private Message an FIMA1  Schreiben Sie einen Gästebucheintrag für FIMA1

Beiträge: 144
Registriert: 05.06.2012

erstellt am: 21. Jan. 2019 11:40    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für THW1701 10 Unities + Antwort hilfreich

Hey Tom,

hat denn der Artikel im Reiter Funktionsschablone irgendwelche Daten stehen?
(Diese sollten mit den Anschlüssen übereinstimmen!)

Gruß
Jo

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

THW1701
Mitglied



Sehen Sie sich das Profil von THW1701 an!   Senden Sie eine Private Message an THW1701  Schreiben Sie einen Gästebucheintrag für THW1701

Beiträge: 11
Registriert: 27.04.2018

EPLAN Education Version (64-Bit)
Version: 2.8 HF2

erstellt am: 22. Jan. 2019 09:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Makro.PNG


Orginal_Makro.PNG

 
Hallo Zusammen,

danke schon mal für die Antworten. Leider hat noch nichts geholfen.

Ich beschreib mal nochmal mein genaues Vorgehen.

Ich zeichne einen Gerätekasten und entferne hier das sichtbare BMK.
Nun setzte ich meine Geräteanschlüsse in den Kasten. Auch hier entferne ich das sichtbare BMK und füge als Anschlusbezeichnung z.B. N oder L ein.
Jetzt speichere ich das Ganze als Symbolmakro ab, indem ich auf Bearbeiten --> Fenster- / Symbolmakro erstellen gehe und dann mein gezeichnetes Bauteil markiere.


Nun hab ich mir einen Artikel angelegt. Dieser ist ein Gleichrichter allgemein.
Als Funktionsschablone für diesen Artikel nehme ich als Geräteauswahl den Gleichrichter variabel. Dieser hat meines Wissens keine Begrenzung der Anschlüsse.
In eben dieser Geräteauswahl stelle ich auch unter Symbolmakros das von mir erstellte Makro ein.
Und dann speichere ich das Ganze.


Wenn ich diesen Artikle nun in einem Schaltplan einfüge, dann wird der Artikel auch als T1 für Gleichrichter eingefügt. Soweit so schön. Aber die Geräteanschlüsse sind das Problem. Aber auch nicht alle. Siehe Bild.
Einige der Geräteanschlüsse ordnen sich warum auch immer dem Geräte T1 zu. Daher auch die Querverweise. Diese verweisen also Auf die Geräteanschlüsse des Bauteils.

Ich habe das jetzt in dem Bild mal etwas auseinandergezogen, damit man sieht um welche Geräteanschlüsse es sich handelt. Im Bild Orginal_Makro sieht man, wie das Makro eigentlich aussehen sollte.


Mir ist einfach nicht klar, warum nur einige Geräteanschlüsse betroffen sind und bei den Anderen die Beschreibung so dabei steht wie ich es haben will.

Ich hoffe, ich konnte klar machen, wo das Problem liegt.
Vielleicht könnt ihr mir nochmal helfen.

Schöne Grüße

Tom


[Diese Nachricht wurde von THW1701 am 22. Jan. 2019 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

sabernia
Mitglied
Elektrokonstrukteur


Sehen Sie sich das Profil von sabernia an!   Senden Sie eine Private Message an sabernia  Schreiben Sie einen Gästebucheintrag für sabernia

Beiträge: 359
Registriert: 21.07.2011

EPLAN Electric P8
Professional 2.7 HF2
Addon(s):
Pro Panel Professional

erstellt am: 22. Jan. 2019 12:29    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für THW1701 10 Unities + Antwort hilfreich

Cheers!

ggf. könnte es helfen, bei den Geräteanschlüssen die Eigenschaft BMK-Übernahme <20035> auf "Nur von Kästen" zu stellen.

Erstellst du die Makros eigentlich aus einem Makroprojekt oder direkt aus den produktiven Projekten?

Mir ist auch nicht klar, wieso du das als Symbolmakro (*.ems)speicherst - diese sollen ja eigentlich in der Funktionsschablone der jeweiligen Artikel verwendet werden - ich denke ein "Fenstermakro" (*.ema) wäre in deinem Fall die bessere Wahl und dieses gehört dann an dem Artikel unter "Technische Daten" -> Makro hinterlegt.
Eine Funktionsschablone braucht es dafür dann nicht unbedingt, wenn es eine gibt, muss sie genau dein Makro abbilden (also Gerätekasten ü die Anschlüsse mit deren Bezeichnung). Aber das nur am Rande ;-)

Grüßen!

------------------
Der Klügere gibt so lange nach, bis er der Dumme ist!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

THW1701
Mitglied



Sehen Sie sich das Profil von THW1701 an!   Senden Sie eine Private Message an THW1701  Schreiben Sie einen Gästebucheintrag für THW1701

Beiträge: 11
Registriert: 27.04.2018

EPLAN Education Version (64-Bit)
Version: 2.8 HF2

erstellt am: 24. Jan. 2019 10:22    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Zitat:
Original erstellt von sabernia:
Cheers!

ggf. könnte es helfen, bei den Geräteanschlüssen die Eigenschaft BMK-Übernahme <20035> auf "Nur von Kästen" zu stellen.

Erstellst du die Makros eigentlich aus einem Makroprojekt oder direkt aus den produktiven Projekten?

Mir ist auch nicht klar, wieso du das als Symbolmakro (*.ems)speicherst - diese sollen ja eigentlich in der Funktionsschablone der jeweiligen Artikel verwendet werden - ich denke ein "Fenstermakro" (*.ema) wäre in deinem Fall die bessere Wahl und dieses gehört dann an dem Artikel unter "Technische Daten" -> Makro hinterlegt.
Eine Funktionsschablone braucht es dafür dann nicht unbedingt, wenn es eine gibt, muss sie genau dein Makro abbilden (also Gerätekasten ü die Anschlüsse mit deren Bezeichnung). Aber das nur am Rande ;-)

Grüßen!



Hallo,

vielen Dank für die Antowort, dass mit dem Fenstermakro hat geholfen.
Auch dass ich es unter technische Daten und nicht in der Funktionsschablone gespeichert habe. Juhu. Vielen Dank.

Warum nicht gleich als Fenstermakro? Weil ich dachte, ich brauche ein Symbol, also Symbolmakro. Und ganz ehrlich, ist mir der Unterschied zwischen Fenster und Symbolmakro noch nicht ganz klar.

Und ich hab das Makro direkt aus einem produktiven Projekt. Auch hier bin ich noch unwissend, was denn ein Makroprojekt ist. Da muss ich mal die Hilfe kontaktieren.

Vielen Dank auf alle Fälle.

Schöne Grüße

Tom

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

sabernia
Mitglied
Elektrokonstrukteur


Sehen Sie sich das Profil von sabernia an!   Senden Sie eine Private Message an sabernia  Schreiben Sie einen Gästebucheintrag für sabernia

Beiträge: 359
Registriert: 21.07.2011

EPLAN Electric P8
Professional 2.7 HF2
Addon(s):
Pro Panel Professional

erstellt am: 25. Jan. 2019 10:36    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für THW1701 10 Unities + Antwort hilfreich

Sehr schön ^^

mach das, ein Makroprojekt ist die einzig wahre Art seine Makros zu verwalten - glaube mit der Meinung bin ich nicht alleine ;-)

Die Symbolmakros nimmt man (so hab ich das verstanden), wenn in der Funktionsschablone ein Standardsymbol nicht passt - z.B. hat ein Schließer in seiner Logik standardmäßig 2 Ziele je Anschluss eingestellt. Nun gibt es Betriebsmittel, da geht nur ein Ziel.
Da baue ich mir dann aus dem Symbol ein Symbolmakro (in allen Drehvarianten) mit der angepassten Logik und hinterlegte dieses dann in der Funktionsschablone.

Sobald etwas aus mehreren Symbolen (Gerätekasten + Anschlüsse) besteht, ist ein Fenstermakro das mittel der Wahl.

Grüßen!

------------------
Der Klügere gibt so lange nach, bis er der Dumme ist!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz