Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  EPLAN Electric P8
  Eplan P8 Analoge Adressenformate

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Eplan P8 Analoge Adressenformate (1293 mal gelesen)
Michi81
Mitglied


Sehen Sie sich das Profil von Michi81 an!   Senden Sie eine Private Message an Michi81  Schreiben Sie einen Gästebucheintrag für Michi81

Beiträge: 8
Registriert: 30.09.2015

erstellt am: 30. Sep. 2015 08:20    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo zusammen,

ich bin neu hier und habe jetzt zu meinem Problem keinen offenen Beitrag gefunden.

Ich habe das Problem das ich die Analogen Ein-/Ausgänge nicht Adressieren kann.

Unter Projekte/Betriebsmittel/SPS-spezifische Einstellungen/Karte Adressformate kann ich dieses einstellen. Aber funktioniert nicht.

Danke für eure Hilfe.

Mfg
Michi

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Christof G
Mitglied
Steuerungstechniker


Sehen Sie sich das Profil von Christof G an!   Senden Sie eine Private Message an Christof G  Schreiben Sie einen Gästebucheintrag für Christof G

Beiträge: 960
Registriert: 09.11.2006

EPlan Electric P8 2.8 Build 12754
EPlan 5.70 SP1 HF2 Prof.
Win7 SP1 Prof. 64Bit

erstellt am: 30. Sep. 2015 08:56    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Michi81 10 Unities + Antwort hilfreich

Hi Michi,

mach mal einen Screenshot von den Eigenschaften des Analoganschlusses.
(erstes Register sollte reichen)

Gruß Christof

------------------
alles wird gut!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Michi81
Mitglied


Sehen Sie sich das Profil von Michi81 an!   Senden Sie eine Private Message an Michi81  Schreiben Sie einen Gästebucheintrag für Michi81

Beiträge: 8
Registriert: 30.09.2015

erstellt am: 30. Sep. 2015 09:24    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Unbenannt.PNG

 
Hallo Christof,

danke für deine Antwort. Ich habe Dir ein Bild angehängt. Ich denke das man den Zähler einstellen muss. Anfangswert bis Endwert und Anzahl stellen.

Gruß Michi

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Christof G
Mitglied
Steuerungstechniker


Sehen Sie sich das Profil von Christof G an!   Senden Sie eine Private Message an Christof G  Schreiben Sie einen Gästebucheintrag für Christof G

Beiträge: 960
Registriert: 09.11.2006

EPlan Electric P8 2.8 Build 12754
EPlan 5.70 SP1 HF2 Prof.
Win7 SP1 Prof. 64Bit

erstellt am: 30. Sep. 2015 11:19    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Michi81 10 Unities + Antwort hilfreich

Hi Michi,

bei diesen Einstellungen habe ich über 0 drin stehen.
Ich dachte an ein Bildchen vom SPS-Anschluss, den Du nummerieren möchtest. Einfach bei den Eigenschaften das 1. Register..

Gruß Christof

------------------
alles wird gut!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Michi81
Mitglied


Sehen Sie sich das Profil von Michi81 an!   Senden Sie eine Private Message an Michi81  Schreiben Sie einen Gästebucheintrag für Michi81

Beiträge: 8
Registriert: 30.09.2015

erstellt am: 30. Sep. 2015 11:30    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Unbenannt.PNG

 
Hallo Christof,

danke. Ich habe nochmal ein Bild angehängt das du haben möchtest. Aber ich denke das ich in dem anderen Bereich schon richig war. Zumindest habe ich es soweit einstellen können das eine automatische Adressierung erfolgt. Aber mit dem Ergebniss das statt dem z.B. PAW272 ein A272 gemacht wird. Er greift auf den Datentyp Bool und nicht auf das Word zu. Da auch die Schrittweite nicht 2 sonder nur 1 ist.

Gruß Michi

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

JochenNie
Mitglied
Elektrokonstrukteur


Sehen Sie sich das Profil von JochenNie an!   Senden Sie eine Private Message an JochenNie  Schreiben Sie einen Gästebucheintrag für JochenNie

Beiträge: 253
Registriert: 15.05.2013

EPLAN Electric P8 - Professional
Version: 2.3 HF1
Version: 2.5 HF2
Version: 2.6 HF2

erstellt am: 30. Sep. 2015 11:58    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Michi81 10 Unities + Antwort hilfreich

Hallo,

Du hast den Datentyp auf "BOOL" stehen. Bitte hier "WORD" eintragen.

Gruß Jochen

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Michi81
Mitglied


Sehen Sie sich das Profil von Michi81 an!   Senden Sie eine Private Message an Michi81  Schreiben Sie einen Gästebucheintrag für Michi81

Beiträge: 8
Registriert: 30.09.2015

erstellt am: 30. Sep. 2015 12:36    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Unbenannt.PNG

 
Hallo,

nein steht leider schon das richtige drin. Siehe Bild. Er solllte auf die dritte Zeile PAW (Word, Schrittweite 2) zugreifen. Greift aber auf die Kannung A (Bool) vor und macht aber das zweite komische die Schrittwete 1 von der zweiten Zeile Byte.

Gruß Michi

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Christof G
Mitglied
Steuerungstechniker


Sehen Sie sich das Profil von Christof G an!   Senden Sie eine Private Message an Christof G  Schreiben Sie einen Gästebucheintrag für Christof G

Beiträge: 960
Registriert: 09.11.2006

EPlan Electric P8 2.8 Build 12754
EPlan 5.70 SP1 HF2 Prof.
Win7 SP1 Prof. 64Bit

erstellt am: 30. Sep. 2015 12:39    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Michi81 10 Unities + Antwort hilfreich

Hi Michi,

mach mal ein Bild vom SPS-Anschluss

------------------
alles wird gut!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Michi81
Mitglied


Sehen Sie sich das Profil von Michi81 an!   Senden Sie eine Private Message an Michi81  Schreiben Sie einen Gästebucheintrag für Michi81

Beiträge: 8
Registriert: 30.09.2015

erstellt am: 30. Sep. 2015 12:44    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Unbenannt.PNG

 
Hallo,

ich denke wir werden es hinbekommen.  Ist sicher wo ne Kleinigkeit. Im Anhang das Bild vom SPS Anschluss. Wobei ich nicht glaube das an dem liegt.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

nairolf
Ehrenmitglied
Elektroingenieur


Sehen Sie sich das Profil von nairolf an!   Senden Sie eine Private Message an nairolf  Schreiben Sie einen Gästebucheintrag für nairolf

Beiträge: 1790
Registriert: 21.01.2006

EPLAN Electric P8 2.8.3 12666 HF2 Ultimate
EPLAN Pro Panel Professional Addon
EPLAN Fluid Addon

erstellt am: 30. Sep. 2015 12:56    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Michi81 10 Unities + Antwort hilfreich

Ich denk schon dass es an dem liegt.
Wurde vorhin schon geschrieben:
Der Datentyp am Anschluss ist falsch !
Bool -> Word

------------------
Der Fuchs ist schlau und stellt sich dumm.
Bei vielen ist es andersrum 
------------------------------------------
Da lernt man mühevoll laufen und sprechen,
und nun soll ich stillsitzen und die Klappe halten !

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Christof G
Mitglied
Steuerungstechniker


Sehen Sie sich das Profil von Christof G an!   Senden Sie eine Private Message an Christof G  Schreiben Sie einen Gästebucheintrag für Christof G

Beiträge: 960
Registriert: 09.11.2006

EPlan Electric P8 2.8 Build 12754
EPlan 5.70 SP1 HF2 Prof.
Win7 SP1 Prof. 64Bit

erstellt am: 30. Sep. 2015 13:24    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Michi81 10 Unities + Antwort hilfreich

yep! BOOL -> WORD 


Info: wenn Du unten bei den Eigenschaften des SPS-Kastens mit der Hauptfunktion auf den Stern drückst, kannst Du die Eigenschaft "Startadresse der SPS-Karte <20419>" anzeigen und editieren.
Dort kannst Du z.B. 276 eintragen und beim adressieren nimmt Eplan dann diesen Wert.

Gruß Christof

------------------
alles wird gut!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

JochenNie
Mitglied
Elektrokonstrukteur


Sehen Sie sich das Profil von JochenNie an!   Senden Sie eine Private Message an JochenNie  Schreiben Sie einen Gästebucheintrag für JochenNie

Beiträge: 253
Registriert: 15.05.2013

EPLAN Electric P8 - Professional
Version: 2.3 HF1
Version: 2.5 HF2
Version: 2.6 HF2

erstellt am: 30. Sep. 2015 13:30    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Michi81 10 Unities + Antwort hilfreich

Hallo Michi,

ich glaube Du überschreibst Dir Deine Bilder hier im Forum. Die Bilder , die Du hochlädst dürfen NIE den gleichen Namen haben. Bei Dir heißen die immer "Unbenannt.PNG".

Gruß Jochen

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Michi81
Mitglied


Sehen Sie sich das Profil von Michi81 an!   Senden Sie eine Private Message an Michi81  Schreiben Sie einen Gästebucheintrag für Michi81

Beiträge: 8
Registriert: 30.09.2015

erstellt am: 30. Sep. 2015 13:37    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Unbenannt1.PNG


Unbenannt2.PNG

 
Hi ihr beiden,

danke. Jetzt sollte es mit den Bildern passen.
Und ich bekomme es einfach nicht hin. 

Gruß Michi

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

JochenNie
Mitglied
Elektrokonstrukteur


Sehen Sie sich das Profil von JochenNie an!   Senden Sie eine Private Message an JochenNie  Schreiben Sie einen Gästebucheintrag für JochenNie

Beiträge: 253
Registriert: 15.05.2013

EPLAN Electric P8 - Professional
Version: 2.3 HF1
Version: 2.5 HF2
Version: 2.6 HF2

erstellt am: 30. Sep. 2015 14:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Michi81 10 Unities + Antwort hilfreich


2015-09-3014_23_01-http___ww3.cad.de_foren_ubb_uploads_Michi81_Unbenannt.PNG.jpg

 
Hallo,

nur noch einmal zum sicher gehen. Hast Du den Eintrag am SPS-Anschluss wie im Screenshot vorgenommen?

Gruß Jochen

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Michi81
Mitglied


Sehen Sie sich das Profil von Michi81 an!   Senden Sie eine Private Message an Michi81  Schreiben Sie einen Gästebucheintrag für Michi81

Beiträge: 8
Registriert: 30.09.2015

erstellt am: 30. Sep. 2015 14:42    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Danke,

jetzt hat es funktioniert. Was so ein kleines Detail alles ausmacht.

Gruß Michi

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

JOHZ
Mitglied
Eletrotechniker


Sehen Sie sich das Profil von JOHZ an!   Senden Sie eine Private Message an JOHZ  Schreiben Sie einen Gästebucheintrag für JOHZ

Beiträge: 35
Registriert: 23.07.2008

Windows 10 Enterprise, EPLAN P8 Prof. V2.7 Build 11418
Xeon E5-1620, 8GB RAM

erstellt am: 01. Okt. 2015 07:16    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Michi81 10 Unities + Antwort hilfreich

Wobei alle analogen Siemens Baugruppen der S7 300er Reihe von Anfang an diesen Fehler (BOOL statt WORD) beinhalten (Baugruppenübersichtsmakros), sowohl im Dataportal, als auch auf der separaten Makro-DVD. Und ich habe mir regelrecht die Zähne ausgebissen, als ich es melden wollte. EPLAN sagt, das liegt alleine in der Verantwortung vom Datenlieferanten (Siemens) und dort sind meine Hinweise im Sand verlaufen.
Dazu kommt noch, dass streng genommen nur z.B. der + Anschluss als SPS-E/A Klemme definiert werden dürfte, weil die Zuordnungsliste, die ja idealer Weise im-/exportfähig sein soll, nun mal pro Kanal nur ein Symbol enthalten darf.

[Diese Nachricht wurde von JOHZ am 01. Okt. 2015 editiert.]

[Diese Nachricht wurde von JOHZ am 01. Okt. 2015 editiert.]

[Diese Nachricht wurde von JOHZ am 01. Okt. 2015 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz