Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  EPLAN Electric P8
  Adressierung Analogkarte (siemens)

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Adressierung Analogkarte (siemens) (3050 mal gelesen)
hunghu
Mitglied


Sehen Sie sich das Profil von hunghu an!   Senden Sie eine Private Message an hunghu  Schreiben Sie einen Gästebucheintrag für hunghu

Beiträge: 4
Registriert: 17.07.2013

erstellt am: 17. Jul. 2013 22:11    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Leute,

ich bin seit ein paar Wochen Eplan Nutzer und habe bisher leider "nur" den 3-Tage Compact Kurs besuchen können.
Bin gerade über folgendes Problem gestolpert:
Ich habe eine S7-300 Analogkarte (7KF02) eingefügt und wollte diese mit Adresse versehen.
Leider mach mir die Adressierungsfunktion immer E528, E529, E530 usw. daraus, anstatt PEW528, PEW530, PEW532 usw.
Das Siemens Makro hat an den Pins IWX, IWX+2, IWX+4 stehen, was ja eigentlich passen sollte.
Wie bekomme ich aber jetzt das System dazu PEW statt E zu schreiben und vor allem in Zweischritten die Adresse zu inkrementieren?
Hat da jemand vielleicht einen Tip für mich?

Viele Grüße
Florian

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

JochenNie
Mitglied
Elektrokonstrukteur


Sehen Sie sich das Profil von JochenNie an!   Senden Sie eine Private Message an JochenNie  Schreiben Sie einen Gästebucheintrag für JochenNie

Beiträge: 253
Registriert: 15.05.2013

EPLAN Electric P8 - Professional
Version: 2.3 HF1
Version: 2.5 HF2
Version: 2.6 HF2

erstellt am: 18. Jul. 2013 07:40    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hunghu 10 Unities + Antwort hilfreich


SPSKartenaddressieren.jpg

 
Hallo,

schau Dir mal den Anhang an. Das Beispiel ist mit "Simatic-S7 I/Q" Einstellungen, du kannst für Dich die Einstellungen "Simatic-S7 E/A" auswählen und anpassen.

Gruß Jochen

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

hunghu
Mitglied


Sehen Sie sich das Profil von hunghu an!   Senden Sie eine Private Message an hunghu  Schreiben Sie einen Gästebucheintrag für hunghu

Beiträge: 4
Registriert: 17.07.2013

erstellt am: 18. Jul. 2013 08:19    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Jochen,

danke für das Beispiel. Dort hat die Karte ja schon die Adressen PIW0...PIW14.
Bei mir hat die Karte allerdings im Adressfeld IWX...IWX+14 stehen.
Und damit kommt das Adressierungstool offensichtlich nicht klar.
Ich habe die Karte jetzt per Hand umgestellt, aber auch damit lässt sich die Adressierung nachher nicht automatisch ändern.
Ist da vielleicht was am Makro faul?

Gruss Florian

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

hunghu
Mitglied


Sehen Sie sich das Profil von hunghu an!   Senden Sie eine Private Message an hunghu  Schreiben Sie einen Gästebucheintrag für hunghu

Beiträge: 4
Registriert: 17.07.2013

erstellt am: 18. Jul. 2013 09:16    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,

Falls jemand nochmal auf dieses Problem stösst:
ich habe es mittlerweile über den Eplan Support klären können.
In diesem Fall war ein kleiner Fehler im Makro von Siemens.
Und zwar war in dieser Eigenschaften-Tabelle im Eigenschafter-Fenster der Anschlüsse
als Datentyp Bool eingetragen. Mit Word hats dann direkt geklappt.

Gruss Florian

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

RU1000
Mitglied
Techniker


Sehen Sie sich das Profil von RU1000 an!   Senden Sie eine Private Message an RU1000  Schreiben Sie einen Gästebucheintrag für RU1000

Beiträge: 51
Registriert: 14.10.2012

Eplan P8 Pro 2.6

erstellt am: 04. Sep. 2013 22:45    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hunghu 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von hunghu:
Hallo,

Falls jemand nochmal auf dieses Problem stösst:
ich habe es mittlerweile über den Eplan Support klären können.
In diesem Fall war ein kleiner Fehler im Makro von Siemens.
Und zwar war in dieser Eigenschaften-Tabelle im Eigenschafter-Fenster der Anschlüsse
als Datentyp Bool eingetragen. Mit Word hats dann direkt geklappt.

Gruss Florian


Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

RU1000
Mitglied
Techniker


Sehen Sie sich das Profil von RU1000 an!   Senden Sie eine Private Message an RU1000  Schreiben Sie einen Gästebucheintrag für RU1000

Beiträge: 51
Registriert: 14.10.2012

Eplan P8 Pro 2.6

erstellt am: 04. Sep. 2013 22:48    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hunghu 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von hunghu:
Hallo,

Falls jemand nochmal auf dieses Problem stösst:
ich habe es mittlerweile über den Eplan Support klären können.
In diesem Fall war ein kleiner Fehler im Makro von Siemens.
Und zwar war in dieser Eigenschaften-Tabelle im Eigenschafter-Fenster der Anschlüsse
als Datentyp Bool eingetragen. Mit Word hats dann direkt geklappt.

Gruss Florian


Hallo Florian,

Kannst du mir erklären wie ich an diese Einstellungen komme?
Habe schon probiert diese raus zu finden leider ohne Erfolg.

Vielem Dank im voraus

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

hunghu
Mitglied


Sehen Sie sich das Profil von hunghu an!   Senden Sie eine Private Message an hunghu  Schreiben Sie einen Gästebucheintrag für hunghu

Beiträge: 4
Registriert: 17.07.2013

erstellt am: 04. Sep. 2013 22:58    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,

Du musst im SPS Navigator alle SPS Pins markieren und dann unter rechte maus-->Eigenschaften in dieser Tabelle bool auf Word umstellen.
Habe grad kein Eplan zur Hand deshalb ist die Beschreibung nicht sehr präzise.
Falls du es nicht findest sag nochmal Bescheid, dann mach ich morgen mal Screenshots.

Gruß florian

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

JochenNie
Mitglied
Elektrokonstrukteur


Sehen Sie sich das Profil von JochenNie an!   Senden Sie eine Private Message an JochenNie  Schreiben Sie einen Gästebucheintrag für JochenNie

Beiträge: 253
Registriert: 15.05.2013

EPLAN Electric P8 - Professional
Version: 2.3 HF1
Version: 2.5 HF2
Version: 2.6 HF2

erstellt am: 05. Sep. 2013 07:08    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hunghu 10 Unities + Antwort hilfreich


sps.jpg

 
Hallo,

hier noch ein Screenshot von den Eigenschaften einens SPS-Anschlusses, wo Du die Einstellungen vornehmen kannst.

Gruß Jochen

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz