Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  ELCAD
  Übertragen von Daten über Verbindungen

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Übertragen von Daten über Verbindungen (1254 mal gelesen)
JensS
Mitglied



Sehen Sie sich das Profil von JensS an!   Senden Sie eine Private Message an JensS  Schreiben Sie einen Gästebucheintrag für JensS

Beiträge: 176
Registriert: 29.03.2010

erstellt am: 07. Jul. 2011 11:02    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo ECLAD-Gemeinde,

ich habe ein Problem mit Übertragen von Daten über Verbindungen.

Ich möchte von einem EA-Symbol den Inhalt des Symb. OP in den Kommentar (Code 40) zu dem angeschlossenen Gerät übertragen. Der Kommentar ist im Endgerät leer. Das Übertragen funktioniert bei mir nur, wenn an dem EA-Symbol eine Hauptdarstellung (Typ 5) angeschlossen ist. Bei einer Nebendarstellung (Typ 6) funktioniert das nicht. Weitere Symboltypen habe ich noch nicht getestet.

Laut Hilfe können mögliche Endgeräte vom Symboltyp 1, 4, 5, 6, 10, 11 und 12 sein. Weiter steht "Bei Symbolen vom Typ 6 in ELCAD/AUCOPLAN Studio-Projekten kann die Codenummer 40 ebenfalls nur übertragen, aber nicht überschrieben werden."

Woran könnte es liegen oder verstehe ich die Hilfe nicht richtig? (Ich benutze ELCAD 7.5.1 mit Studio)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Erwin Fortelny
Mitglied
Tech. Zeichner


Sehen Sie sich das Profil von Erwin Fortelny an!   Senden Sie eine Private Message an Erwin Fortelny  Schreiben Sie einen Gästebucheintrag für Erwin Fortelny

Beiträge: 871
Registriert: 13.12.2001

-Firma:
Lenovo S30 + 2x Acer B246HL, Win7 x64 Enterprise
AutoCAD 10 bis 2014
ELCAD 3.5 bis 7.12

erstellt am: 07. Jul. 2011 11:06    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für JensS 10 Unities + Antwort hilfreich

Hallo,

Zitat:
Original erstellt von JensS:
Das Übertragen funktioniert bei mir nur, wenn an dem EA-Symbol eine Hauptdarstellung (Typ 5) angeschlossen ist. Bei einer Nebendarstellung (Typ 6) funktioniert das nicht. Weitere Symboltypen habe ich noch nicht getestet.

Hmm, beim Typ 6 funktioniert es - AFAIKAs far as i know (So viel ich weiss)/IMO - nur, wenn man bei der Mutter (Typ 5) und bei den Töchtern (Typ 6) im Code 1000 auch die Code-Zeile des Kommentars als Bedingung benutzt!?

------------------
Servus, Erwin
--

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

JensS
Mitglied



Sehen Sie sich das Profil von JensS an!   Senden Sie eine Private Message an JensS  Schreiben Sie einen Gästebucheintrag für JensS

Beiträge: 176
Registriert: 29.03.2010

erstellt am: 07. Jul. 2011 11:18    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Wird der Kommentar nicht immer abgeglichen? Bei mir ist der 1000er Code nicht mit im Übertrager.

Mein Ziel:  EA-Symbol Code 12212 --> angeschlossen an --> Nebendarstellung Code 40 --> Abgleich zu --> Hauptdarstellung Code 40

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

JensS
Mitglied



Sehen Sie sich das Profil von JensS an!   Senden Sie eine Private Message an JensS  Schreiben Sie einen Gästebucheintrag für JensS

Beiträge: 176
Registriert: 29.03.2010

erstellt am: 07. Jul. 2011 14:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Ich meinte bei mir ist der Kommentarcode 40 nicht mit im Übertrager (1000er Code)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP


Ex-Mitglied

erstellt am: 08. Jul. 2011 08:44    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat

Hallo,

der Code 40 wir nur automatisch zwischen Mutter/Tochter übertragen, wenn man die
Elcad-Studio-Lizenz hat. (Siehe Elcad-Demo-Projekt, das wurde mit Studio erstellt.)

Hat man ein Projekt ohne Studio, muss der Code 40 mit in den 1000er.

~EDIT~
T'schuldigung, ich hatte nicht gesehen, dass Du die Daten über die Verbindung
übertragen möchtest...

------------------
Viele Grüße aus Erlangen
Uli

           

JensS
Mitglied



Sehen Sie sich das Profil von JensS an!   Senden Sie eine Private Message an JensS  Schreiben Sie einen Gästebucheintrag für JensS

Beiträge: 176
Registriert: 29.03.2010

erstellt am: 08. Jul. 2011 10:45    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo UKanz,

ich benutze Studio. Die Frage ist, warum bei mir die Daten von dem EA-Symbol nicht in eine angeschlossene Tochter übertragen werden? Bzw. Daten werden schon übertragen, aber nicht der Code 40.

Und in den Töchtern etwas basteln möchte ich nicht. So wie zum Beispiel übertrage Code xxxxx vom EA Symbol in Code yyyy im Tochertymbol und anschließend übertrage Code yyyy in Code 40.


Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP


Ex-Mitglied

erstellt am: 08. Jul. 2011 12:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat

Hallo Jens,

ich stehe gerade ziemlich auf der Leitung, da hier anscheinend zwei
verschiedene Themen miteinander vermischt werden.

Möchtest Du den Code 40 von einer E/A-Mutter an eine E/A-Tochter übertragen?

Oder möchtest Du den Code 40 von einer E/A-Tochter (über die Verbindung) an
ein Endgerät übertragen?

------------------
Viele Grüße aus Erlangen
Uli

           

JensS
Mitglied



Sehen Sie sich das Profil von JensS an!   Senden Sie eine Private Message an JensS  Schreiben Sie einen Gästebucheintrag für JensS

Beiträge: 176
Registriert: 29.03.2010

erstellt am: 08. Jul. 2011 13:57    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Uli,

[EA-Symbol: Code 12212] ---> [Muttersymbol: Code 40] => alles schön
[EA-Symbol: Code 12212] ---> [Tochtersymbol: Code 40] => Problem

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP


Ex-Mitglied

erstellt am: 08. Jul. 2011 14:07    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat

Zitat:
Original erstellt von JensS:
[EA-Symbol: Code 12212] ---> [Tochtersymbol: Code 40] => Problem

Hallo Jens,

was ist denn ein EA-Symbol? Eine Tochter? Mutter? Tante?
Von einem EA-Symbol in eine Tochter? Sorry, ich verstehe gar nichts... 

------------------
Viele Grüße aus Erlangen
Uli

           

JensS
Mitglied



Sehen Sie sich das Profil von JensS an!   Senden Sie eine Private Message an JensS  Schreiben Sie einen Gästebucheintrag für JensS

Beiträge: 176
Registriert: 29.03.2010

erstellt am: 08. Jul. 2011 15:42    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Ok, nochmal gaaanz laaangsaaam  

An dem EA-Symbol Typ 6 wird Zuordnungslistentext angezeigt. Der Symbolische Operant soll von dem EA-Symbol Typ 6 in ein elektrisch angeschlossenes Gerät an der Verbindung übertragen werden und in den Gerätekommentar Code 40 geschrieben werden.

Ist das an das EA-Symbol Typ 6 angeschlossen Symbol vom Typ 5 wird der Kommentar übertragen. Alles prima. Ist jedoch an das EA-Symbol Typ 6 ein Symbol vom Typ 6 angeschlossen, wird der Kommentar NICHT übertragen. Darin liegt mein Problem.

Ist doch ganz einfach     ... und so etwas zum Freitag Nachmittag

[EDIT] Der Begriff EA-Symbol stammt aus der ELCAD Hilfe zu dem Thema "Übertragen von Daten über Verbindungen"

[Diese Nachricht wurde von JensS am 08. Jul. 2011 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP


Ex-Mitglied

erstellt am: 08. Jul. 2011 16:06    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat

 
~gelöscht, da falsch~

------------------
Viele Grüße aus Erlangen
Uli

           


Ex-Mitglied

erstellt am: 08. Jul. 2011 16:14    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat

Habe eine Lösung gefunden:

Nach einem Projekt-Check erscheint der Text am Typ-5-Endgerät.

Zeichnung schließen / Extras / Dienste / ProjektCheck

~EDIT~
Das war Unfug, bitte die obige Antwort vergessen! 

In der Hilfe steht:

Zitat:
Durch das Schließen des Blattes, auf dem Einzel-E/A-Symbole dargestellt sind, wird die Übertragungsfunktion für diese E/A-Symbole aktiviert.

Beim Öffnen eines Blattes, auf dem Einzel-E/A-Symbole oder deren Endgeräte dargestellt sind, werden diese Symbole oder Endgeräte mit den zu übertragenen Informationen aktualisiert.


Da ich die Zeichnung für den Projektcheck geschlossen und geöffnet habe......
Bei mir klappt es auch mit Blatt vor/zurück.

------------------
Viele Grüße aus Erlangen
Uli

           

JensS
Mitglied



Sehen Sie sich das Profil von JensS an!   Senden Sie eine Private Message an JensS  Schreiben Sie einen Gästebucheintrag für JensS

Beiträge: 176
Registriert: 29.03.2010

erstellt am: 12. Jul. 2011 10:53    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Ukranz,

Danke für den Test. Bei mir funktioniert es nicht. Habe es soeben nochmal getestet. Kann das am Studio liegen? (ELCAD751)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP


Ex-Mitglied

erstellt am: 12. Jul. 2011 10:58    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat

Hallo Jens,

gestern habe ich schon einen Brief erhalten, in dem man mich auch mit einem R geschrieben hat.   

Ich konnte es nur mit der 760 testen, da ich die 751 nicht habe. Aber vielleicht kann es
Bodo ja mal für Dich probieren und berichten.

------------------
Viele Grüße aus Erlangen
Uli

           

JensS
Mitglied



Sehen Sie sich das Profil von JensS an!   Senden Sie eine Private Message an JensS  Schreiben Sie einen Gästebucheintrag für JensS

Beiträge: 176
Registriert: 29.03.2010

erstellt am: 12. Jul. 2011 13:10    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Ukanz,

das "r" nehme ich zurück, ich bitte um Vergebung   


Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP


Ex-Mitglied

erstellt am: 12. Jul. 2011 13:17    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat

Sage doch einfach "Uli" zu mir. 

------------------
Viele Grüße aus Erlangen
Uli

           

JensS
Mitglied



Sehen Sie sich das Profil von JensS an!   Senden Sie eine Private Message an JensS  Schreiben Sie einen Gästebucheintrag für JensS

Beiträge: 176
Registriert: 29.03.2010

erstellt am: 14. Jul. 2011 07:25    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Geht klar Uli, Danke

Schön wäre, wenn Bodo mein Problem mal bei sich nachstellen könnte 

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP


Ex-Mitglied

erstellt am: 14. Jul. 2011 08:15    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat

Hallo Jens,

was ich gerade aus der Schaltanlagentechnik gehört habe, haben Bodo und Kollegen
gerade keinen Strom. Oder hat man Euch schon wieder angeknipst, Bodo? 

------------------
Viele Grüße aus Erlangen
Uli

           

Bodo_M
Moderator





Sehen Sie sich das Profil von Bodo_M an!   Senden Sie eine Private Message an Bodo_M  Schreiben Sie einen Gästebucheintrag für Bodo_M

Beiträge: 5241
Registriert: 15.11.2001

erstellt am: 14. Jul. 2011 09:13    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für JensS 10 Unities + Antwort hilfreich

hallo zusammen,

wir haben seit stunden wieder strom und nun funktioniert auch das
internet wieder.

@Jens......wende dich bitte an die Elcad hotline (0511 6103 120)

------------------
tschüss aus hannover
bodo m

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP



Elektrokonstrukteur (m/w/d) EPLAN
Sie interessieren sich für spannende Projekte? In den unterschiedlichsten Branchen? Dann sind Sie bei FERCHAU richtig. Als Marktführer stehen wir mit mehr als 8.260 Mitarbeitern an über 100 Niederlassungen und Standorten seit vielen Jahren für die ganze Welt des Engineerings. Unseren namhaften Kunden bieten wir individuelle Lösungen für neue technische Herausforderungen. Ihnen eröffnen wir die Möglichkeit, durch Leistung Ihre Zukunft selbst zu steuern....
Anzeige ansehenElektrotechnik, Elektronik
JensS
Mitglied



Sehen Sie sich das Profil von JensS an!   Senden Sie eine Private Message an JensS  Schreiben Sie einen Gästebucheintrag für JensS

Beiträge: 176
Registriert: 29.03.2010

erstellt am: 14. Jul. 2011 16:34    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Bodo,

danke für den Hinweis. Die Hotline (Herr Brecht) und ich sind drauf gekommen, dass die ELCAD-Hilfe FALSCH sein muss, bzw. die praktische Realität mit der Theorie nicht übereinstimmt 

  

Zitat:
Bei Symbolen vom Typ 6 in ELCAD/AUCOPLAN Studio-Projekten kann die Codenummer 40 ebenfalls nur übertragen, aber nicht überschrieben werden.

Im Aucoplan/Studio wurde mal was am Übertragen von Code 40 und ZL gesperrt meinte er. Deshalb geht das Übertragen in meinem Fall nicht.

Richtig müsste die Hilfe lauten:

Bei Symbolen vom Typ 6 in ELCAD/AUCOPLAN Studio-Projekten kann die Codenummer 40 NICHT übertragen werden.


[Diese Nachricht wurde von JensS am 15. Jul. 2011 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz