Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  ELCAD
  Falcher Gerätetyp

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:  Falcher Gerätetyp (3333 mal gelesen)
FayloBedo
Mitglied


Sehen Sie sich das Profil von FayloBedo an!   Senden Sie eine Private Message an FayloBedo  Schreiben Sie einen Gästebucheintrag für FayloBedo

Beiträge: 6
Registriert: 26.03.2002

erstellt am: 22. Sep. 2004 13:49    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hi
arbeite erst seit kurzen mit Elcad 7.2
habe ein neues SPS-Symbol aus einem bestehende erstellt.
in der ersten Zeichnung funktioniert es einwandfrei.in der
nächsten zeichnung fehlen mir Querverweise.Ich habe das Hauptsymbol daraufhin gelöscht und aus dem Blatt 1 kopiert und editiert.
Nun bekomme ich beim auswerten den Fehler "falcher Gerätetyp"
wer kann mir helfen?

Gruss
Andreas

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Bodo_M
Moderator





Sehen Sie sich das Profil von Bodo_M an!   Senden Sie eine Private Message an Bodo_M  Schreiben Sie einen Gästebucheintrag für Bodo_M

Beiträge: 5274
Registriert: 15.11.2001

erstellt am: 22. Sep. 2004 13:52    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich

hallo,

dein relais hat keine freien kontakte mehr........wenn erst das
relais ausgewertet wird kommt die meldung "kontakt nicht vorgesehn
oder frei".

tschüss aus hannover
bodo m

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

s.koni
Mitglied
Elektrotechnischer Zeichner


Sehen Sie sich das Profil von s.koni an!   Senden Sie eine Private Message an s.koni  Schreiben Sie einen Gästebucheintrag für s.koni

Beiträge: 314
Registriert: 17.06.2002

ELCAD 7.8.0
EPLAN P8 2.4.4

erstellt am: 22. Sep. 2004 17:50    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich

Hallo FayloBedo,

kann es sein, das die CPU-Nr nicht übereinstimmt? Oder die Bezeichnung des DI/DO nicht auf der Karte editiert ist?

mfg
s.koni

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

06Sanny
Mitglied
Konstruktionsassistentin


Sehen Sie sich das Profil von 06Sanny an!   Senden Sie eine Private Message an 06Sanny  Schreiben Sie einen Gästebucheintrag für 06Sanny

Beiträge: 76
Registriert: 02.07.2002

erstellt am: 23. Sep. 2004 11:27    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich

Hi Faylo,

stimmen die 1000er Codes überein??? Ist mir auch schon passiert und da stimmten die Abfragen von 1000er Code nicht überein...

------------------
Gruß
Sandra

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Bodo_M
Moderator





Sehen Sie sich das Profil von Bodo_M an!   Senden Sie eine Private Message an Bodo_M  Schreiben Sie einen Gästebucheintrag für Bodo_M

Beiträge: 5274
Registriert: 15.11.2001

erstellt am: 23. Sep. 2004 11:35    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich

hallo,

sach ich doch.....keine freie kontakte mehr heisst keine freie
1000er codes..........oder falscher inhalt, sprich in deinem relais
ist noch ein öffner frei aber du hast einen schliesser zuviel.

tschüss aus hannover
bodo m

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP


Ex-Mitglied

erstellt am: 23. Sep. 2004 13:41    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat

Hallo,

"Kontakt nicht vorgesehen oder frei": Meist falsche Anschlüsse, oder Muttersymbol voll belegt.

"Falscher Gerätetyp": Der Buchstabe im Identifikator passt nicht, z.B: ("S",13,14)

Gruß Uli

Bodo_M
Moderator





Sehen Sie sich das Profil von Bodo_M an!   Senden Sie eine Private Message an Bodo_M  Schreiben Sie einen Gästebucheintrag für Bodo_M

Beiträge: 5274
Registriert: 15.11.2001

erstellt am: 23. Sep. 2004 13:52    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich

hallo,

einmal sag ich es noch...  ....die meldungen haben dieselbe ursache,
es kommt nur auf die reihenfolge der auswertung an:

1. erst das relais ausgewertet, dann die kontakte: kontakt nicht
  vorgesehn oder frei.
2. erst die kontakte ausgewertet: falscher gerätetyp

tschüss aus hannover
bodo m

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP


Ex-Mitglied

erstellt am: 23. Sep. 2004 15:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat

Hallo Bodo,

so gesehen hast Du natürlich Recht, aber da ich immer das Hauptsymbol zuerst auswerte, kam ich gar nicht auf die Idee mit dem Rückwärts-Auswerten...

Gruss Uli

Julia1234
Mitglied
Zeichner


Sehen Sie sich das Profil von Julia1234 an!   Senden Sie eine Private Message an Julia1234  Schreiben Sie einen Gästebucheintrag für Julia1234

Beiträge: 54
Registriert: 26.02.2021

erstellt am: 12. Jul. 2021 15:04    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich


Schutz.PNG

 
Zitat:
Original erstellt von FayloBedo:
Hi
arbeite erst seit kurzen mit Elcad 7.2
habe ein neues SPS-Symbol aus einem bestehende erstellt.
in der ersten Zeichnung funktioniert es einwandfrei.in der
nächsten zeichnung fehlen mir Querverweise.Ich habe das Hauptsymbol daraufhin gelöscht und aus dem Blatt 1 kopiert und editiert.
Nun bekomme ich beim auswerten den Fehler "falcher Gerätetyp"
wer kann mir helfen?

Gruss
Andreas



Hallo bei mir steht auch, dass es ein Falscher Gerätetyp ist.
Die 1000er Nummern usw stimmen denke ich. (Foto)
An was kann das noch liegen?
Das Schütz findet die Kontakte nicht.


Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Julia1234
Mitglied
Zeichner


Sehen Sie sich das Profil von Julia1234 an!   Senden Sie eine Private Message an Julia1234  Schreiben Sie einen Gästebucheintrag für Julia1234

Beiträge: 54
Registriert: 26.02.2021

erstellt am: 12. Jul. 2021 15:06    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich

Julia1234
Mitglied
Zeichner


Sehen Sie sich das Profil von Julia1234 an!   Senden Sie eine Private Message an Julia1234  Schreiben Sie einen Gästebucheintrag für Julia1234

Beiträge: 54
Registriert: 26.02.2021

erstellt am: 12. Jul. 2021 15:12    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich


Fehler.PNG

 
Zitat:
Original erstellt von Julia1234:
Noch ein Foto

Das Zeigt er am Kontakt an


Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Bodo_M
Moderator





Sehen Sie sich das Profil von Bodo_M an!   Senden Sie eine Private Message an Bodo_M  Schreiben Sie einen Gästebucheintrag für Bodo_M

Beiträge: 5274
Registriert: 15.11.2001

erstellt am: 13. Jul. 2021 07:24    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich

moin Julia,

das ist das geleiche, kommt nur auf die reihenfolge der auswertung an.
symbolt typ 5 und 6 (also mama und tochter) passen im 1000er code nicht. s/ö oder kontaktnummern. di kannst es provozieren, wenn du
einem schütz mit 2 öffnern einen dritten zuordnest und auswertest.
dann kommt dieser fehler.

------------------
tschüss aus hannover
bodo m

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Julia1234
Mitglied
Zeichner


Sehen Sie sich das Profil von Julia1234 an!   Senden Sie eine Private Message an Julia1234  Schreiben Sie einen Gästebucheintrag für Julia1234

Beiträge: 54
Registriert: 26.02.2021

erstellt am: 13. Jul. 2021 10:55    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von Bodo_M:
moin Julia,

das ist das geleiche, kommt nur auf die reihenfolge der auswertung an.
symbolt typ 5 und 6 (also mama und tochter) passen im 1000er code nicht. s/ö oder kontaktnummern. di kannst es provozieren, wenn du
einem schütz mit 2 öffnern einen dritten zuordnest und auswertest.
dann kommt dieser fehler.


Hi Bodo,

laut Dialogfenster, was du im Bild sehen kannst, ist doch alles in Ordnung.
Oder siehst du da einen Fehler?
Oder was meinst du ?

[Diese Nachricht wurde von Julia1234 am 13. Jul. 2021 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Erwin Fortelny
Mitglied
Tech. Zeichner


Sehen Sie sich das Profil von Erwin Fortelny an!   Senden Sie eine Private Message an Erwin Fortelny  Schreiben Sie einen Gästebucheintrag für Erwin Fortelny

Beiträge: 877
Registriert: 13.12.2001

-Firma:
Lenovo P51 + 2x Acer B276HL, Win10 x64 Enterprise
AutoCAD 2019
ELCAD Pro 2020

erstellt am: 14. Jul. 2021 09:47    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich

Hallo,

Zitat:
Original erstellt von Julia1234:
laut Dialogfenster, was du im Bild sehen kannst, ist doch alles in Ordnung.
Oder siehst du da einen Fehler?


Ist das Symbol "Original" oder ein Eigenbau?!

Zitat:
Original erstellt von Julia1234:
Oder was meinst du ?


Wenn ich mir das Bild vom Schütz so ansehen, dann erkennt man dort ja, das der Kontakt 23-24 schon belegt ist!

Daher kommt dann auch die Meldung beim Bild von Kontakt, der ja auch auf 23-24 lautet ... frei wäre ja nur noch 43-44 beim Schütz.

------------------
Servus, Erwin
--

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Julia1234
Mitglied
Zeichner


Sehen Sie sich das Profil von Julia1234 an!   Senden Sie eine Private Message an Julia1234  Schreiben Sie einen Gästebucheintrag für Julia1234

Beiträge: 54
Registriert: 26.02.2021

erstellt am: 19. Jul. 2021 10:08    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von Erwin Fortelny:
Hallo,


Wenn ich mir das Bild vom Schütz so ansehen, dann erkennt man dort ja, das der Kontakt 23-24 schon belegt ist!

Daher kommt dann auch die Meldung beim Bild von Kontakt, der ja auch auf 23-24 lautet ... frei wäre ja nur noch 43-44 beim Schütz.




Halb halb :-)

der Fehler lag in der Tabelle an den Nummern 14,15,16 und 17.
In der Zeile muss jeweil die 3 weg, es muss überall richtig heißen
("S","13","14")>(10) usw

Gruß

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Julia12345
Mitglied
Studentin


Sehen Sie sich das Profil von Julia12345 an!   Senden Sie eine Private Message an Julia12345  Schreiben Sie einen Gästebucheintrag für Julia12345

Beiträge: 14
Registriert: 14.12.2021

erstellt am: 11. Jan. 2022 10:38    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich


F1.PNG


F2.PNG


F3.PNG

 
Hallo
Habe wieder das Problem mit den Gerätetypen.
Alle Schütze sind gleich (8K1-8K8)
Bei 8K3 und 8K4 wird falscher Gerätetyp angezeigt und bei allen
anderen geht die Auswertung obwohl alle die gleichen Typen sind.
Kann mir da einer weiter helfen?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Julia12345
Mitglied
Studentin


Sehen Sie sich das Profil von Julia12345 an!   Senden Sie eine Private Message an Julia12345  Schreiben Sie einen Gästebucheintrag für Julia12345

Beiträge: 14
Registriert: 14.12.2021

erstellt am: 11. Jan. 2022 10:39    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich

Bodo_M
Moderator





Sehen Sie sich das Profil von Bodo_M an!   Senden Sie eine Private Message an Bodo_M  Schreiben Sie einen Gästebucheintrag für Bodo_M

Beiträge: 5274
Registriert: 15.11.2001

erstellt am: 11. Jan. 2022 14:37    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich

hallo Julia,

gleiche meldung.......gleicher fehler

du hast dem relais zu viele kontakte zugeordnet

------------------
tschüss aus hannover
bodo m

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Julia12345
Mitglied
Studentin


Sehen Sie sich das Profil von Julia12345 an!   Senden Sie eine Private Message an Julia12345  Schreiben Sie einen Gästebucheintrag für Julia12345

Beiträge: 14
Registriert: 14.12.2021

erstellt am: 11. Jan. 2022 14:58    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von Bodo_M:
hallo Julia,

gleiche meldung.......gleicher fehler

du hast dem relais zu viele kontakte zugeordnet


wie meinst du das mit zu vielen Kontakte zugeordnet?
Das Relais 8K3 hat nur einen Schließer Kontakt /10.3 zugeordnet sonst nichts.
Das Relais 8K4 hat nur einen Schließer Kontakt /10.4 zugeordnet sonst nichts.

Die anderen Relais die ausgewertet sind haben noch mehr Kontakte zugeordnet und funktionieren,
obwohl das genau die gleichen Relais sind wie die nicht ausgewerteten (Geräte Fehler)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Julia12345
Mitglied
Studentin


Sehen Sie sich das Profil von Julia12345 an!   Senden Sie eine Private Message an Julia12345  Schreiben Sie einen Gästebucheintrag für Julia12345

Beiträge: 14
Registriert: 14.12.2021

erstellt am: 11. Jan. 2022 15:20    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich

Hab den Fehler gefunden. Danke

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP



Elektro-CAD Konstrukteur_in (w/d/m)

Die MINDA Industrieanlagen GmbH ist ein weltweit agierendes Familienunternehmen des Maschinen- und Anlagenbaus. Wir entwickeln, produzieren und vertreiben spezifische Intralogistik-Lösungen für die Wellpappen- und Massivholzindustrie. Als einer der Branchenführer suchen wir für unseren Stammsitz in Minden zum nächstmöglichen Zeitpunkt eine_n engagierte_n und motivierte_n Elektro-CAD Konstrukteur_in (w/d/m) | T13....

Anzeige ansehenKonstruktion, Visualisierung
Bodo_M
Moderator





Sehen Sie sich das Profil von Bodo_M an!   Senden Sie eine Private Message an Bodo_M  Schreiben Sie einen Gästebucheintrag für Bodo_M

Beiträge: 5274
Registriert: 15.11.2001

erstellt am: 12. Jan. 2022 08:15    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für FayloBedo 10 Unities + Antwort hilfreich

moin Julia,

kommt "kontakt nicht vorgesehen oder frei" oder "falscher gerätetyp",
je nach reihenfolge der auswertung, handelt es sich immmer um den
gleichen fehler.  

------------------
tschüss aus hannover
bodo m

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2022 CAD.de | Impressum | Datenschutz