Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  SolidWorks
   Installationspaket Passungstabelle 8.2.0.0

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
  
Gut zu wissen: SOLIDWORKS - DFMXpress
Autor Thema:   Installationspaket Passungstabelle 8.2.0.0 (1321 mal gelesen)
nahe
Ehrenmitglied



Sehen Sie sich das Profil von nahe an!   Senden Sie eine Private Message an nahe  Schreiben Sie einen Gästebucheintrag für nahe

Beiträge: 1563
Registriert: 18.01.2001

arbeite mit:
HP Z440 Workstation
Xenon (12-Kern) 3.5GHz
32GB RAM
238GB SSD
------------------------
SWX-2018 SP5.0
EPDM
----------------
Windows 7 64 bit
----------------
VB.net
VB
VBA
Lotus Notes Datenbanken
erste Schritte mit Swift

erstellt am: 10. Jan. 2020 11:39    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Passungstabelle-8-2-0-0.zip

 
Hallo zusammen,

nachdem, dank Eurer Mithilfe, wieder ein paar Fehler behoben werden konnten,
anbei das neue Installationspaket.

Versionshinweise für Version 8.2.0.0
- da durch die Windows Einstellung "Region und Sprache" auch das Dezimaltrennzeichen umgestellt wird,
  wenn z.B.: Englisch eingestellt wird, wurde die Tabelle nicht richtig abgebildet,
  die Einstellung sollte nun keinen Einfluss mehr auf die Tabellenerzeugung haben

- die Log-Datei wird nun im Verzeichnis C:\Users\Benutzername\AppData\Roaming\nahe\Passungstabelle gespeichert
  damit sollte auch das Problem mit fehlenden Schreibrechten behoben sein
 
- zusätzlich wird geprüft ob in dem Verzeichnis der Log-Datei eine Datei erstellt werden kann
  falls das nicht möglich ist, wird das Makro trotzdem ordnungsgemäß ausgeführt

Installationshinweise
- die bestehende Version über die Systemsteuerung deinstallieren
- dann die neue Version installieren
- eine bereits vorhandene Setup-Datei wird bei der Deinstallation nicht gelöscht
  und bei der Installation auch nicht ersetzt
  trotzdem würde ich empfehlen, vor der Installation, eine Kopie der Setup-Datei zu erstellen

Hinweise
- es sollte auch reichen, nur die Datei "Passungstabellen.dll" im Installationsverzeichnis zu ersetzen
- Allerdings werden dann die Hilfe-Dateien nicht aktualisiert

Wie immer,
Wünsche, Anregungen und Kritik, sind jederzeit willkommen und erwünscht

------------------
Grüße
Heinz

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

schwarzr
Mitglied
Konstrukteur


Sehen Sie sich das Profil von schwarzr an!   Senden Sie eine Private Message an schwarzr  Schreiben Sie einen Gästebucheintrag für schwarzr

Beiträge: 16
Registriert: 29.11.2019

erstellt am: 06. Mrz. 2020 11:28    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für nahe 10 Unities + Antwort hilfreich


Teil1.PDF

 
Hallo Heinz,
uns ist noch eine Kleinigkeit bei der Passungstabelle aufgefallen.
Wenn der Durchmesser eines zylindrischen Teils in der Seitenansicht bemaßt wird, und vor dem Maß z.B. „2x“ steht, verschwindet in der Passungstabelle das Durchmesserzeichen.
Bei Bemaßungen in der Draufsicht nicht, auch nicht bei eingefügten Bohrungsbeschreibungen mit Passung.
Anbei ein PDF mit der Darstellung (im Beispiel das Maß 2x Ø42,1H7).

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

nahe
Ehrenmitglied



Sehen Sie sich das Profil von nahe an!   Senden Sie eine Private Message an nahe  Schreiben Sie einen Gästebucheintrag für nahe

Beiträge: 1563
Registriert: 18.01.2001

arbeite mit:
HP Z440 Workstation
Xenon (12-Kern) 3.5GHz
32GB RAM
238GB SSD
------------------------
SWX-2018 SP5.0
EPDM
----------------
Windows 7 64 bit
----------------
VB.net
VB
VBA
Lotus Notes Datenbanken
erste Schritte mit Swift

erstellt am: 06. Mrz. 2020 11:42    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo schwarzr,

danke für den Hinweis
ich vermute mal, dass das damit zu tun hat,
dass das eine lineare Bemaßung ist und ich das anders auswerte.

Ich wird mir das in den nächsten Tagen ansehen,
kann aber noch keinen Zeitpunkt nennen, bis ich das behoben habe

PS
kannst Du bitte einen screenshot vom Propertymanager der Bemaßung posten,
um zu sehen wie der Bemaßungstext aufgebaut ist


------------------
Grüße
Heinz

[Diese Nachricht wurde von nahe am 06. Mrz. 2020 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

nahe
Ehrenmitglied



Sehen Sie sich das Profil von nahe an!   Senden Sie eine Private Message an nahe  Schreiben Sie einen Gästebucheintrag für nahe

Beiträge: 1563
Registriert: 18.01.2001

arbeite mit:
HP Z440 Workstation
Xenon (12-Kern) 3.5GHz
32GB RAM
238GB SSD
------------------------
SWX-2018 SP5.0
EPDM
----------------
Windows 7 64 bit
----------------
VB.net
VB
VBA
Lotus Notes Datenbanken
erste Schritte mit Swift

erstellt am: 06. Mrz. 2020 12:10    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Passungstabellen-20200306.zip

 
Hallo nochmals,

ich konnte den Fehler nachstellen und
scheinbar war er einfacher als gedacht zu beheben

anbei die neueste Version zum Testen

Einfach im Installationsverzeichnis die bestehende Passungstabellen.dll umbenennen
und mit der aus der ZIP-Datei ersetzen.

Bitte um kurze Info ob das Problem damit behoben ist,
damit ich ein neues Installationspaket bereitstellen kann

Schönes Wochenende

PS
wahrscheinlich muss SWX 1x neu gestartet werden

------------------
Grüße
Heinz

[Diese Nachricht wurde von nahe am 06. Mrz. 2020 editiert.]

[Diese Nachricht wurde von nahe am 06. Mrz. 2020 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

schwarzr
Mitglied
Konstrukteur


Sehen Sie sich das Profil von schwarzr an!   Senden Sie eine Private Message an schwarzr  Schreiben Sie einen Gästebucheintrag für schwarzr

Beiträge: 16
Registriert: 29.11.2019

erstellt am: 06. Mrz. 2020 13:12    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für nahe 10 Unities + Antwort hilfreich

Hallo Heinz,
ja, das funktioniert so.
Vielen Dank für die schnelle Hilfe!

------------------
Grüße,
Rainer

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

nahe
Ehrenmitglied



Sehen Sie sich das Profil von nahe an!   Senden Sie eine Private Message an nahe  Schreiben Sie einen Gästebucheintrag für nahe

Beiträge: 1563
Registriert: 18.01.2001

arbeite mit:
HP Z440 Workstation
Xenon (12-Kern) 3.5GHz
32GB RAM
238GB SSD
------------------------
SWX-2018 SP5.0
EPDM
----------------
Windows 7 64 bit
----------------
VB.net
VB
VBA
Lotus Notes Datenbanken
erste Schritte mit Swift

erstellt am: 09. Mrz. 2020 13:06    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo zusammen,

bevor ich die Anpassung freigebe, noch eine Frage in die Runde
jetzt wird die Anzeige des Ø Zeichens durch folgende Bedingungen erzwungen

- wenn die Bemaßung eine Durchmesserbemaßung ist
oder
- wenn im Bemaßungs-Prefix-Text "<MOD-DIAM>" vorkommt
oder
- wenn im Bemaßungs-Prefix-Text "Ø" vorkommt

die Frage ist nur,
gibt es unter Umständen einen Bemaßungs-Prefix-Text
in dem "<MOD-DIAM>" und/oder "Ø" vorkommt und trotzdem kein Ø gesetzt werden soll?

------------------
Grüße
Heinz

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

schwarzr
Mitglied
Konstrukteur


Sehen Sie sich das Profil von schwarzr an!   Senden Sie eine Private Message an schwarzr  Schreiben Sie einen Gästebucheintrag für schwarzr

Beiträge: 16
Registriert: 29.11.2019

erstellt am: 10. Mrz. 2020 06:34    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für nahe 10 Unities + Antwort hilfreich

Hallo Heinz,
da fällt mir kein Fall ein.

------------------
Grüße,
Rainer

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Obi1317
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Obi1317 an!   Senden Sie eine Private Message an Obi1317  Schreiben Sie einen Gästebucheintrag für Obi1317

Beiträge: 20
Registriert: 15.02.2016

Win7, SWX2019 (WIN10 in Vorbereitung)

erstellt am: 19. Mrz. 2020 10:44    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für nahe 10 Unities + Antwort hilfreich

Hallo,

wir haben ein paar Modelle/Zeichnungen, bei denen das Einfügen der Passungstabelle zum Absturz führt.
Nutzer Rawo hatte im Thread der Version 8.1.0.3 ein (vermeintlich) gleiches Problem beschrieben:

"So, habe nochmal paar Tests gemacht... der Fehler tritt nur bei einer ganzen Reihe an Zeichnungen auf, die aus ein und derselben Part-Datei mit vielen Konfigurationen erzeugt wurden.
Keine Ahnung, was an den 3D-Daten so besonders ist, dass die Passungstabelle in den zugehörigen Zeichnungen nen Absturz verursacht.
Passiert auch, wenn ich eine neue Zeichnung aus dieser Datei / andere Konfiguration, erstellen will."

Gab es damals dafür eine Lösung?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

nahe
Ehrenmitglied



Sehen Sie sich das Profil von nahe an!   Senden Sie eine Private Message an nahe  Schreiben Sie einen Gästebucheintrag für nahe

Beiträge: 1563
Registriert: 18.01.2001

arbeite mit:
HP Z440 Workstation
Xenon (12-Kern) 3.5GHz
32GB RAM
238GB SSD
------------------------
SWX-2018 SP5.0
EPDM
----------------
Windows 7 64 bit
----------------
VB.net
VB
VBA
Lotus Notes Datenbanken
erste Schritte mit Swift

erstellt am: 19. Mrz. 2020 13:12    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Obi1317,

das kann ich leider nicht beantworten, am besten wird wohl sein,
wenn Du Dich dirket, per PM, an rawo wendest.

Da ich die Datei nicht kenne kann ich auch leider keinen Hinweis geben.

Wenn Du die Datei hier posten kannst/darfst, dann kann ich mir das mal ansehen.
Da ich aber durch die aktuelle Situation nur eingeschränkt Zugriff
auf mein SWX habe, kann eine Lösungsfindung etwas dauern.

Ein anderer Ansatz wäre, wenn das möglich ist,
versuchsweise das Teil mal teilweise neu aufzubauen.


------------------
Grüße
Heinz

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Obi1317
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Obi1317 an!   Senden Sie eine Private Message an Obi1317  Schreiben Sie einen Gästebucheintrag für Obi1317

Beiträge: 20
Registriert: 15.02.2016

Win7, SWX2019 (WIN10 in Vorbereitung)

erstellt am: 19. Mrz. 2020 15:06    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für nahe 10 Unities + Antwort hilfreich


Z035883_Test.sldprt


Z035883_Test.slddrw

 
Hallo nahe,

Das Teil auf anderem Wege aufzubauen, habe ich versucht, leider ohne Erfolg. Aus dem Grund habe ich Teil und Zeichnung hochgeladen. Solltest Du Möglichkeit, Zeit und Muße haben, Dir das mal anzuschauen, wäre ich sehr dankbar!

Grüße
Tomek

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

nahe
Ehrenmitglied



Sehen Sie sich das Profil von nahe an!   Senden Sie eine Private Message an nahe  Schreiben Sie einen Gästebucheintrag für nahe

Beiträge: 1563
Registriert: 18.01.2001

arbeite mit:
HP Z440 Workstation
Xenon (12-Kern) 3.5GHz
32GB RAM
238GB SSD
------------------------
SWX-2018 SP5.0
EPDM
----------------
Windows 7 64 bit
----------------
VB.net
VB
VBA
Lotus Notes Datenbanken
erste Schritte mit Swift

erstellt am: 20. Mrz. 2020 09:51    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Passungstabellen-20200320.zip

 
Hallo Tomek,

ich konnte die Ursache feststellen
Selbst wenn alle Bemaßungen und Angaben in der Zeichnung gelöscht werden,
gibt die Funktion zur Ermittlung der Bemaßungen ein Maß zurück.
Das Maß hat die Variable "D7", den Wert 0 und ist eine Radiusbemaßung.
Komischerweise kann ich nirgends eine Bemaßung mit "D7" finden.

Ich hab das jetzt mal so programmiert, dass alle Maße mit dem Wert 0
übersprungen werden.
Ob das die endgültige Lösung für das Problem ist, kann ich nicht sagen.

Mir ist schleierhaft, von wo diese Bemaßung kommt.

Im Anhang findest Du eine aktualisierte dll.
Einfach die bestehende dll im Installationsverzeichnis umbenennen und
mit der vom Anhang ersetzen.

Bitte schreib kurz zurück, ob das neue Add-In funktioniert.

------------------
Grüße
Heinz

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Obi1317
Mitglied
Konstrukteur


Sehen Sie sich das Profil von Obi1317 an!   Senden Sie eine Private Message an Obi1317  Schreiben Sie einen Gästebucheintrag für Obi1317

Beiträge: 20
Registriert: 15.02.2016

Win7, SWX2019 (WIN10 in Vorbereitung)

erstellt am: 20. Mrz. 2020 12:43    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für nahe 10 Unities + Antwort hilfreich

Hallo Heinz,

der Hammer, ganz herzlichen Dank für Deine Mühen!
Das mit dem Maß "D7" ist tatsächlich merkwürdig, dafür habe ich auch keine Erklärung. Allerdings habe ich das Teil auch nicht selber modelliert. Dass Du trotz offensichtlichem Fehler im Teil eine Lösung in Deinem Tool eingefügt hast, finde ich großartig! Hab es in mehreren Zeichnungen getestet und bis jetzt gab es keine Probleme.
Noch einmal ein dickes Dankeschön!

Grüße
Tomek

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

bk.sc
Ehrenmitglied V.I.P. h.c.
Konstrukteur Sondermaschinenbau



Sehen Sie sich das Profil von bk.sc an!   Senden Sie eine Private Message an bk.sc  Schreiben Sie einen Gästebucheintrag für bk.sc

Beiträge: 2461
Registriert: 18.07.2012

-Solid Works 2019 SP3
-Pro Engineer WF 3

erstellt am: 20. Mrz. 2020 13:30    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für nahe 10 Unities + Antwort hilfreich

Hallo,

ich würde tippen dass das Teil vorher einen Radius hatte der auch bemaßt war und im nachhinein gelöscht wurde. Nach dem löschen wird die Bemaßung nicht wie üblich als freistehend in einer anderen Farbe dargestellt sondern verschwindet einfach (hat ein Test meinerseits ergeben). Kann man Bemassungen auf freistehen überprüfen? Evtl. währe das die geschicktere Variante als auf 0 zu prüfen, da es ja durchaus Firmen gibt die diese Funktionalität nützen das Maße nicht gelöscht wird sondern eben freistehend vorhanden bleibt und über die Systemoptionen eben nicht dargestellt wird.

Ich könnte mir vorstellen das dass ein SWX 2019 Bug ist, weil ich hab wage in Erinnerung das in anderen Versionen Radiusbemaßungen auch freistehend angezeigt wurden.

Gruß
Bernd

------------------
--- Man muß nicht alles wissen, man muß nur wissen wo es steht ---

Staatlich anerkannte Deutschniete 

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

nahe
Ehrenmitglied



Sehen Sie sich das Profil von nahe an!   Senden Sie eine Private Message an nahe  Schreiben Sie einen Gästebucheintrag für nahe

Beiträge: 1563
Registriert: 18.01.2001

arbeite mit:
HP Z440 Workstation
Xenon (12-Kern) 3.5GHz
32GB RAM
238GB SSD
------------------------
SWX-2018 SP5.0
EPDM
----------------
Windows 7 64 bit
----------------
VB.net
VB
VBA
Lotus Notes Datenbanken
erste Schritte mit Swift

erstellt am: 20. Mrz. 2020 15:16    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Bernd,

danke für den Tipp
Ich werd mal schauen was ich da sonst noch
Über diese Bemaßung rausfinde und werd mich nochmals melden

------------------
Grüße
Heinz

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

nahe
Ehrenmitglied



Sehen Sie sich das Profil von nahe an!   Senden Sie eine Private Message an nahe  Schreiben Sie einen Gästebucheintrag für nahe

Beiträge: 1563
Registriert: 18.01.2001

arbeite mit:
HP Z440 Workstation
Xenon (12-Kern) 3.5GHz
32GB RAM
238GB SSD
------------------------
SWX-2018 SP5.0
EPDM
----------------
Windows 7 64 bit
----------------
VB.net
VB
VBA
Lotus Notes Datenbanken
erste Schritte mit Swift

erstellt am: 21. Mrz. 2020 12:37    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


dang-01.PNG


dang-02.PNG

 
Hallo zusammen,

der Tipp von Bernd, war der Richtige.
Anbei zwei screenshots
wenn ich die Zeichnung aus Bild 1 als abgelöste Zeichnung speichere
und dann wieder öffne, kommt die Darstellung von Bild 2
die markierte Bemaßung ist ein freistehende Bemaßung.

Komisch an der Sache ist auch,
wenn ich das Makro mit der abgelösten Zeichnung laufen lasse
gibt die nicht freistehende Bemaßung folgendes zurück
dimension.systemvalue 0,02
dimension.getsystemvalue3(1,"") nothing
dimension.value 0

lt. Dokumentation sollte man SystemValue aber nicht mehr verwenden
sondern GetSystemValue3

Für mich ziehe ich jetzt daraus bis auf weiteres den Schluss
folgende Bemaßungen werden nicht ausgewertet
- freistehende Bemaßungen
- Bemaßungen die als Value 0 zurückgeben
  wer weiß wie lange Systemvalue noch richtige Werte liefert

Allgemein heißt das auch, dass das Add In nicht dafür geeignet ist
abgelöste Zeichnungen ordentlich zu handhaben

Frage an Alle die das Add In verwenden
Ist das für Euch so ok?

PS
da es bei Bemaßungen in abgelösten Zeichnungen nicht möglich ist
die Passung zu ändern, fällt die Möglichkeit den Wert von SystemValue zu verwenden flach.

Das Ändern der Passung ist notwendig um Bemaßungen mit Passungspaarungen wie z.B.: H7/m6
auszuwerten.

------------------
Grüße
Heinz

[Diese Nachricht wurde von nahe am 21. Mrz. 2020 editiert.]

[Diese Nachricht wurde von nahe am 21. Mrz. 2020 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

rawo
Ehrenmitglied
technische Zeichnerin


Sehen Sie sich das Profil von rawo an!   Senden Sie eine Private Message an rawo  Schreiben Sie einen Gästebucheintrag für rawo

Beiträge: 1591
Registriert: 29.03.2001

-----------------------------------
Nichtstun macht nur Spass, wenn man eigentlich viel zu tun hätte. (Sir Coward)<P>Status: "Konfigurations-Junkie"

erstellt am: 02. Sep. 2020 10:40    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für nahe 10 Unities + Antwort hilfreich

Ich habe ein Problem mit der Passungstabelle im PDM.
Die Kollegen können nicht auf die Setup-Einstellungen zugreifen, keiner bekommt die von mir gespeicherten Einstellungen zur Lage ect. der Tabelle angezeigt.
Da aber die Setup.ini im PDM eingecheckt ist, hat nat. auch kein anderer User Schreibrechte und kann sich die Tabelle nicht neu selbst einrichten.
Gibts hier einen Trick, wie die Kollegen auf die Einstellungen zugreifen können?
Gruß
Ramona

------------------
Kein Mensch ist so beschäftigt, dass er nicht die Zeit hätte, jedem zu erzählen, wie beschäftig er ist.

SWX 2020 SP2 / PDM Professional
Office 2019
Windows 10 Pro 64 bit
Dell Precision T3600
Intel Xeon E5
16 Gb RAM
NVIDIA Quadro P2200
Space Pilot Pro

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

nahe
Ehrenmitglied



Sehen Sie sich das Profil von nahe an!   Senden Sie eine Private Message an nahe  Schreiben Sie einen Gästebucheintrag für nahe

Beiträge: 1563
Registriert: 18.01.2001

arbeite mit:
HP Z440 Workstation
Xenon (12-Kern) 3.5GHz
32GB RAM
238GB SSD
------------------------
SWX-2018 SP5.0
EPDM
----------------
Windows 7 64 bit
----------------
VB.net
VB
VBA
Lotus Notes Datenbanken
erste Schritte mit Swift

erstellt am: 02. Sep. 2020 11:42    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Ramona,

wir verwenden EPDM erst seit kurzer Zeit und ich bin noch nicht richtig fit damit.

Wir haben die Ini Datei nach wie vor außerhalb von EPDM auf einem Serververzeichnis gespeichert

Die einzige Erklärung für mich, warum die Benutzer die Einstellungen nicht angezeigt bekommen wäre, dass die Benutzer die Ini Datei mal holen müssten.
Ich vermute, dass sie sonst nicht im lokalen Workspace vorhanden ist.

Wenn die Datei eingecheckt ist, dann ist es natürlich nicht möglich sie zu ändern.

Dazu müssten Sie Datei auschecken und werden sie wahrscheinlich auch Änderungen vornehmen können.

Das sind aber alles nur Vermutungen.
Aktuell habe ich leider nicht die Zeit mir das mal genauer anzusehen.

Ich könnte mir vorstellen, das Add-In so zu erweitern,
- es wird geprüft ob die Ini Datei in einem EPDM Verzeichnis liegt
  ob und wie man das feststellen kann weiß ich noch nicht
- wenn ja, wird die letzte Version der Datei lokal geholt
- wenn Änderungen an der Ini Datei gemacht werden, wird sie ausgecheckt
- die Änderungen gespeichert und wieder eingecheckt

d.h. aber dann natürlich, dass alle Benutzer diese Einstellungen haben würden

Fragen dazu
- was sollte passieren, wenn jemand das Makro benutzt, während die Datei ausgecheckt ist (d.h. in Änderung ist)?


------------------
Grüße
Heinz

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

rawo
Ehrenmitglied
technische Zeichnerin


Sehen Sie sich das Profil von rawo an!   Senden Sie eine Private Message an rawo  Schreiben Sie einen Gästebucheintrag für rawo

Beiträge: 1591
Registriert: 29.03.2001

-----------------------------------
Nichtstun macht nur Spass, wenn man eigentlich viel zu tun hätte. (Sir Coward)<P>Status: "Konfigurations-Junkie"

erstellt am: 02. Sep. 2020 12:22    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für nahe 10 Unities + Antwort hilfreich

Danke für Deinen Tip. Aber so wie ich das sehe, gibt es ja bei dem neuesten Makro gar keine ini-Datei mehr... ich finde jedenalls keine Aktuelle. Es gibt ja nur noch die Setup.xml und die liegt bei mir selbst auch nicht lokal, nur im PDM und trotzdem funktioniert es... ich werde mal die xml dem Kollegen lokal hinlegen und nochmal neu installieren.

------------------
Kein Mensch ist so beschäftigt, dass er nicht die Zeit hätte, jedem zu erzählen, wie beschäftig er ist.

SWX 2020 SP2 / PDM Professional
Office 2019
Windows 10 Pro 64 bit
Dell Precision T3600
Intel Xeon E5
16 Gb RAM
NVIDIA Quadro P2200
Space Pilot Pro

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

rawo
Ehrenmitglied
technische Zeichnerin


Sehen Sie sich das Profil von rawo an!   Senden Sie eine Private Message an rawo  Schreiben Sie einen Gästebucheintrag für rawo

Beiträge: 1591
Registriert: 29.03.2001

-----------------------------------
Nichtstun macht nur Spass, wenn man eigentlich viel zu tun hätte. (Sir Coward)<P>Status: "Konfigurations-Junkie"

erstellt am: 02. Sep. 2020 12:29    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für nahe 10 Unities + Antwort hilfreich

Habe nochmal neu installiert und die XML dem Kollegen auch lokal gegeben und ins Installationsverzeichnis kopiert... aber geht trotzdem nicht...

Bei meinem Rechner ist es so, da ich auf die eingecheckte XML verweise, kann ich das Setup über SWX nicht ausführen, bekomme die Fehlermeldung, dass die XML schreibgeschützt ist. Genau so, wie es sein sollte.
Beim Kollegen kann ich das Setup in SWX auführen, also die Tabelle anpassen... obwohl ich bei der Installation den PDM-Pfad angegeben habe...

------------------
Kein Mensch ist so beschäftigt, dass er nicht die Zeit hätte, jedem zu erzählen, wie beschäftig er ist.

SWX 2020 SP2 / PDM Professional
Office 2019
Windows 10 Pro 64 bit
Dell Precision T3600
Intel Xeon E5
16 Gb RAM
NVIDIA Quadro P2200
Space Pilot Pro

[Diese Nachricht wurde von rawo am 02. Sep. 2020 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

nahe
Ehrenmitglied



Sehen Sie sich das Profil von nahe an!   Senden Sie eine Private Message an nahe  Schreiben Sie einen Gästebucheintrag für nahe

Beiträge: 1563
Registriert: 18.01.2001

arbeite mit:
HP Z440 Workstation
Xenon (12-Kern) 3.5GHz
32GB RAM
238GB SSD
------------------------
SWX-2018 SP5.0
EPDM
----------------
Windows 7 64 bit
----------------
VB.net
VB
VBA
Lotus Notes Datenbanken
erste Schritte mit Swift

erstellt am: 02. Sep. 2020 14:32    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

sorry, ich meinte natürlich die XML Datei

wie geschrieben, ich hab bisher keine Tests in Verbindung mit EPDM gemacht

Werde das aber in den nächsten Wochen nachholen

------------------
Grüße
Heinz

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

nahe
Ehrenmitglied



Sehen Sie sich das Profil von nahe an!   Senden Sie eine Private Message an nahe  Schreiben Sie einen Gästebucheintrag für nahe

Beiträge: 1563
Registriert: 18.01.2001

arbeite mit:
HP Z440 Workstation
Xenon (12-Kern) 3.5GHz
32GB RAM
238GB SSD
------------------------
SWX-2018 SP5.0
EPDM
----------------
Windows 7 64 bit
----------------
VB.net
VB
VBA
Lotus Notes Datenbanken
erste Schritte mit Swift

erstellt am: 02. Sep. 2020 16:00    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Leider schlechte Nachrichten

Ich hab hier keine Möglichkeit das mit EPDM zu testen, weil der EPDM-Admin keinen Workflow für XML Dateien vorgesehen hat.

Werde versuchen dass, auch XML Dateien in EPDM eingecheckt werden können.
Da das aber über unsere GIT läuft, kann das dauern.

------------------
Grüße
Heinz

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

rawo
Ehrenmitglied
technische Zeichnerin


Sehen Sie sich das Profil von rawo an!   Senden Sie eine Private Message an rawo  Schreiben Sie einen Gästebucheintrag für rawo

Beiträge: 1591
Registriert: 29.03.2001

-----------------------------------
Nichtstun macht nur Spass, wenn man eigentlich viel zu tun hätte. (Sir Coward)<P>Status: "Konfigurations-Junkie"

erstellt am: 09. Sep. 2020 13:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für nahe 10 Unities + Antwort hilfreich

Danke Dir. Wir haben uns jetzt erst einmal so beholfen, dass ich bei dem Kollegen das Makro nur lokal installiert habe und die MXL-Datei mit der aus der Datenbank bei ihm lokal überschrieben habe.

Läuft. Wenn keine Änderungen am Setup erfolgen, ist es ja auch so gut machbar.

------------------
Kein Mensch ist so beschäftigt, dass er nicht die Zeit hätte, jedem zu erzählen, wie beschäftig er ist.

SWX 2020 SP2 / PDM Professional
Office 2019
Windows 10 Pro 64 bit
Dell Precision T3600
Intel Xeon E5
16 Gb RAM
NVIDIA Quadro P2200
Space Pilot Pro

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz