Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  SolidWorks
  Materialdatenbankfehler - Falscher Paramter

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Materialdatenbankfehler - Falscher Paramter (474 mal gelesen)
kutzbach03
Mitglied
Ingenieur Maschinenbau


Sehen Sie sich das Profil von kutzbach03 an!   Senden Sie eine Private Message an kutzbach03  Schreiben Sie einen Gästebucheintrag für kutzbach03

Beiträge: 23
Registriert: 16.05.2017

Solid Edge ST10 und NX 12
Teamcenter 11
OS Windows 7-10

erstellt am: 12. Nov. 2018 10:18    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


12-11-_2018_10-06-19.png

 
Hallo liebe SW-Nutzer,

ich habe das Problem, dass beim Festlegen des Materials in SW (2018 academic, Windows 7) der Fehler kommt: Falscher Parameter (siehe Screenshot). Die Maske für die Materialeinstellungen ist dann leer.

Es war auf dem Rechner vorher SW2017 academic installiert, da hat es noch funktioniert. Einige Pfade waren noch auf SW2017 eingestellt, diese habe ich auf 2018 geändert.

Die benutzerdefinierte DB unter C:\ProgramData\SOLIDWORKS\SOLIDWORKS 2018\Benutzerdefinierte Materialien\Benutzerdefinierte Materialien.sldmat ist vorhanden. Schreibrechte darauf ebenso.

Hat jemand eine Idee?

Vielen Dank im Voraus!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

gogoslav
Mitglied
Maschinenbautechniker


Sehen Sie sich das Profil von gogoslav an!   Senden Sie eine Private Message an gogoslav  Schreiben Sie einen Gästebucheintrag für gogoslav

Beiträge: 678
Registriert: 24.03.2005

WIN 10 x64 Enterprise
SWX 2018 SP5.0
SWX 2019 SP0.0
Visualize Prof 2019 SP0.0
PDM Prof 2019 SP0.0
HP ZBook17 G5
Nvidia Quadro P3200
32 GB RAM
xeon 4,2GHz
dahammerspass

erstellt am: 12. Nov. 2018 10:50    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für kutzbach03 10 Unities + Antwort hilfreich


SWMaterial.zip

 
Hallo,
wahrscheinlich hats die Datenbank zerschossen.
Im Anhang hab ich den Inhalt des Ordners als ZIP angehängt.
Lad Dir das runter, legs in den Ordner, lösche die "alten" Daten im Ordner, entpacke die ZIP.
Wenn Du nun SW startest und ein Materaisl vergibst, sollte keine FM kommen.

Gruß Marco 

------------------
Papa 2005 u 2007
Gib jedem Tag die Chance, der schönste Deines Lebens zu werden.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CAD-Maler
Mitglied
Konstrukteur / CAD-Admin / Mädchen für alles


Sehen Sie sich das Profil von CAD-Maler an!   Senden Sie eine Private Message an CAD-Maler  Schreiben Sie einen Gästebucheintrag für CAD-Maler

Beiträge: 567
Registriert: 17.01.2007

SWX 2017 SP5
AutoCAD 2015
Win 8.1 64 bit
Intel Xeon 3,2GHz
16GB RAM
Nvidia Quadro K2200
SWx EPDM

erstellt am: 12. Nov. 2018 11:44    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für kutzbach03 10 Unities + Antwort hilfreich

Die Meldung kenne ich nur, wenn SolidWorks über eine Pfadangabe stolpert, die länger als die 256-Zeichen-Schmerzgrenze von Windows ist. Besonders oft beim Virtuell-Machen (Kopie von..._Kopie von..._Kopie von...)

Scheint aber hier nicht das Problem zu sein. Oder will SWX evtl. noch eine andere Mat-DB irgendwoher laden? Musst mal in die Dateipositionen in den Systemeinstellungen schauen.

Gruß, Jens

------------------
CSWE =)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Nobbi
Mitglied
Techniker


Sehen Sie sich das Profil von Nobbi an!   Senden Sie eine Private Message an Nobbi  Schreiben Sie einen Gästebucheintrag für Nobbi

Beiträge: 111
Registriert: 21.08.2002

Windows 10 Enterprise
SW2001 - SW2018
MDT
ACPIx64-basierter PC
NVIDIA Quadro M4000
Space Pilot
SAP-Cideon

erstellt am: 12. Nov. 2018 13:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für kutzbach03 10 Unities + Antwort hilfreich


Mat.PNG

 
Hi sieht der Pfad so aus ?
Gruß Nobbi

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

kutzbach03
Mitglied
Ingenieur Maschinenbau


Sehen Sie sich das Profil von kutzbach03 an!   Senden Sie eine Private Message an kutzbach03  Schreiben Sie einen Gästebucheintrag für kutzbach03

Beiträge: 23
Registriert: 16.05.2017

Solid Edge ST10 und NX 12
Teamcenter 11
OS Windows 7-10

erstellt am: 12. Nov. 2018 14:30    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


12-11-_2018_14-26-12.png

 
Danke für die Antworten,

das hat schon mal etwas Licht ins Dunkle gebracht. Das Problem ist allerdings noch, dass der Pfad stimmt und ich die Datenbank-Dateien auch schon mit funktionierenden (die oben angehängten) ersetzt habe, aber der Fehler immer noch kommt.

Ich vermute die Pfade in der Registry stimmen vlt. nicht, könnte das sein? Oder gibt es eine Art Konfigurationsdatei in der die Dateipfade hinterlegt sind. Weiß jemand, wo das hinterlegt ist?

Vielen Dank im Voraus!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

kutzbach03
Mitglied
Ingenieur Maschinenbau


Sehen Sie sich das Profil von kutzbach03 an!   Senden Sie eine Private Message an kutzbach03  Schreiben Sie einen Gästebucheintrag für kutzbach03

Beiträge: 23
Registriert: 16.05.2017

Solid Edge ST10 und NX 12
Teamcenter 11
OS Windows 7-10

erstellt am: 12. Nov. 2018 14:31    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


12-11-_2018_14-33-09.png

 
Danke für die Antworten,

das hat schon mal etwas Licht ins Dunkle gebracht. Das Problem ist allerdings noch, dass der Pfad stimmt und ich die Datenbank-Dateien auch schon mit funktionierenden (die oben angehängten) ersetzt habe, aber der Fehler immer noch kommt.

Ich vermute die Pfade in der Registry stimmen vlt. nicht, könnte das sein? Oder gibt es eine Art Konfigurationsdatei in der die Dateipfade hinterlegt sind. Weiß jemand, wo das hinterlegt ist?

Vielen Dank im Voraus!

[Diese Nachricht wurde von kutzbach03 am 12. Nov. 2018 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Nobbi
Mitglied
Techniker


Sehen Sie sich das Profil von Nobbi an!   Senden Sie eine Private Message an Nobbi  Schreiben Sie einen Gästebucheintrag für Nobbi

Beiträge: 111
Registriert: 21.08.2002

Windows 10 Enterprise
SW2001 - SW2018
MDT
ACPIx64-basierter PC
NVIDIA Quadro M4000
Space Pilot
SAP-Cideon

erstellt am: 12. Nov. 2018 14:45    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für kutzbach03 10 Unities + Antwort hilfreich

Hi regedit + Computer\HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2017\Material
sollte hier sein :-)

Gruß Norbert

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

kutzbach03
Mitglied
Ingenieur Maschinenbau


Sehen Sie sich das Profil von kutzbach03 an!   Senden Sie eine Private Message an kutzbach03  Schreiben Sie einen Gästebucheintrag für kutzbach03

Beiträge: 23
Registriert: 16.05.2017

Solid Edge ST10 und NX 12
Teamcenter 11
OS Windows 7-10

erstellt am: 12. Nov. 2018 15:42    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


12-11-_2018_15-41-12.png

 
Bei der 2018er steht da leider kein Pfad (siehe Screenshot) drin, oder habe ich etwas übersehen 

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

kutzbach03
Mitglied
Ingenieur Maschinenbau


Sehen Sie sich das Profil von kutzbach03 an!   Senden Sie eine Private Message an kutzbach03  Schreiben Sie einen Gästebucheintrag für kutzbach03

Beiträge: 23
Registriert: 16.05.2017

Solid Edge ST10 und NX 12
Teamcenter 11
OS Windows 7-10

erstellt am: 15. Nov. 2018 13:52    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Wir konnten jetzt das Problem zumindest etwas eingrenzen. Der Fehler tritt nur dann auf, wenn die Zusatzanwendung "Simulation" aktiviert ist. 

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CAD-Maler
Mitglied
Konstrukteur / CAD-Admin / Mädchen für alles


Sehen Sie sich das Profil von CAD-Maler an!   Senden Sie eine Private Message an CAD-Maler  Schreiben Sie einen Gästebucheintrag für CAD-Maler

Beiträge: 567
Registriert: 17.01.2007

SWX 2017 SP5
AutoCAD 2015
Win 8.1 64 bit
Intel Xeon 3,2GHz
16GB RAM
Nvidia Quadro K2200
SWx EPDM

erstellt am: 15. Nov. 2018 15:02    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für kutzbach03 10 Unities + Antwort hilfreich

Es gibt unter

HKEY_CURRENT_USER\Software\SolidWorks\SOLIDWORKS 2017\ExtReferences

und

HKEY_CURRENT_USER\Software\SRAC\cosmos/works\COSMOSWorks 2015\Material

noch die Materialpfade. Eventuell...

Gruß, Jens

------------------
CSWE =)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

kutzbach03
Mitglied
Ingenieur Maschinenbau


Sehen Sie sich das Profil von kutzbach03 an!   Senden Sie eine Private Message an kutzbach03  Schreiben Sie einen Gästebucheintrag für kutzbach03

Beiträge: 23
Registriert: 16.05.2017

Solid Edge ST10 und NX 12
Teamcenter 11
OS Windows 7-10

erstellt am: 15. Nov. 2018 15:13    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo, danke für den Hinweis.

Diese Dateipfade habe wir allerdings bereits gecheckt, falls wir nicht etwas übersehen haben, liegt es wahrscheinlich nicht daran.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Heiko Soehnholz
Ehrenmitglied V.I.P. h.c.
Dipl.-Ing. Maschinenbau



Sehen Sie sich das Profil von Heiko Soehnholz an!   Senden Sie eine Private Message an Heiko Soehnholz  Schreiben Sie einen Gästebucheintrag für Heiko Soehnholz

Beiträge: 3897
Registriert: 03.07.2002

SOLIDWORKS seit 2001
CSWS-TSO/MD/TMD
CSWS-C/D/I/MBD/VIS
CSWP-Core/DT/MT/SM/SU/WD
CSWE CSSP CSPP CSWI SWPUC
SOLIDWORKS 2019SP0
Simulation, Composer, MBD,
Inspection, PDMP, Visualize,
TopsWorks, TableAddIn etc.
WIN10 x64 auf HP ZBook 17 G3

erstellt am: 15. Nov. 2018 16:03    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für kutzbach03 10 Unities + Antwort hilfreich


SWXMaterialMitSimulation.jpg

 
Hallo,

sobald das Simulation aktiv ist, werden ja auch die ganzen Materialeigenschaften ausgewertet (E-Modul...), die zuvor keine Rolle für SWX spielten. Und dann kommt noch der ganz neue Reiter mit den tabellarischen Werten und Kurven hinzu.

… irgendwo hier sind unsinnige Werte eingetragen - nehme ich an.

Ist die Fehlermeldung nur bei einem/einigen Materialien, oder kommt sie generell?

------------------
Einen schönen Gruß von Heiko
- www.dps-software.de - www.iknow-solidworks.de -

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

kutzbach03
Mitglied
Ingenieur Maschinenbau


Sehen Sie sich das Profil von kutzbach03 an!   Senden Sie eine Private Message an kutzbach03  Schreiben Sie einen Gästebucheintrag für kutzbach03

Beiträge: 23
Registriert: 16.05.2017

Solid Edge ST10 und NX 12
Teamcenter 11
OS Windows 7-10

erstellt am: 15. Nov. 2018 16:20    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


15-11-_2018_16-16-00.png

 
Hallo, danke für den Hinweis, das hatte ich noch nicht auf dem Schirm.

Die Meldung kommt sofort, wenn man "Material bearbeiten" anklickt bzw. man bei "Material konfigurieren" auf "Weiter durchsuchen..." klickt. Die Favoriten nimmt er komischerweise anstandslos. Ich habe auch bereits die Materialdatenbankdateien ersetzt, der Fehler kommt trotz Verwendung der Originale.


[Diese Nachricht wurde von kutzbach03 am 15. Nov. 2018 editiert.]

[Diese Nachricht wurde von kutzbach03 am 15. Nov. 2018 editiert.]

[Diese Nachricht wurde von kutzbach03 am 15. Nov. 2018 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2018 CAD.de | Impressum | Datenschutz