Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  SolidWorks
  Makroproblem mit Set swApp ....

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Makroproblem mit Set swApp .... (358 mal gelesen)
Joshua63
Mitglied
Maschinenbautechniker


Sehen Sie sich das Profil von Joshua63 an!   Senden Sie eine Private Message an Joshua63  Schreiben Sie einen Gästebucheintrag für Joshua63

Beiträge: 334
Registriert: 08.11.2006

erstellt am: 20. Apr. 2016 10:55    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Zusammen,

Ich habe an einem Rechner ein Problem mit unserem Sücklistenmakro.
Das Makro wird in SWX gestartet, speichert die Stückliste als .TXT ab, öffnet Excel und liest die .TXT in eine Vorlage ein.

An allen anderen Rechnern geht es, nur an einem nicht.

Fehlermeldung:
Laufzeitfehler 13
Typen unverträglich

Der Debugger steht in der Zeile:  Set swApp=Aplication.sldWorks

Da ich mich und andere Kollegen an diesem Rechner angemeldet haben und es geht, kann es eigentlich nur an einer Usereinstellung liegen (denke ich).

Hat jemand eine Idee woran das liegen kann ?

(SWX2012)

Danke

------------------
Viele Wege führen zum Ziel .......... und ich will alle wissen !

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

StefanBerlitz
Guter-Geist-Moderator
IT Admin (CAx)



Sehen Sie sich das Profil von StefanBerlitz an!   Senden Sie eine Private Message an StefanBerlitz  Schreiben Sie einen Gästebucheintrag für StefanBerlitz

Beiträge: 8613
Registriert: 02.03.2000

SunZu sagt:
Analysiere die Vorteile, die
du aus meinem Ratschlag ziehst.
Dann gliedere deine Kräfte
entsprechend und mache dir
außergewöhnliche Taktiken zunutze.

erstellt am: 20. Apr. 2016 11:47    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Joshua63 10 Unities + Antwort hilfreich

Hallo Joshua,

also noch mal langsam: an allen Rechnern geht es bis auf einen. Außer ihr (also du und deine Kollegen) meldet euch da an, dann geht es da auch 

Kann es vielleicht sein, dass unabhängig von demjenigen, der sich dort anmeldet, einer der Rechner diese Laufzeitfehler 13 schmeißt? Dann ist die wahrscheinlichkeit relativ hoch, dass dort

a) irgendein Verweise (unter Extras/Makros) ins Leere zeigt
b) kein SolidWorks installiert ist
c) kein Excel installiert ist

Ich tippe auf a)   

Ciao,
Stefan

------------------
Inoffizielle deutsche SolidWorks Hilfeseite    http://solidworks.cad.de

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

bk.sc
Ehrenmitglied
Maschinenbautechniker


Sehen Sie sich das Profil von bk.sc an!   Senden Sie eine Private Message an bk.sc  Schreiben Sie einen Gästebucheintrag für bk.sc

Beiträge: 1667
Registriert: 18.07.2012

HP Z400 Workstaion
CPU: Intel Xeon 6x 3,33GHz
GPU: NVIDEA Quadro 2000
RAM: 12 GB DDR3
Win 7 x64
CAD Hauptberuflich
-Solid Works 2014 SP4
-Creo Elements Direct Drafting (ME10)
DMS/PDM
-Pro.File V8 (8.4)
Simulation
-Simufact Forming 11.0
CAD Nebenberuflich
-Pro Engineer WF 3+4
-Creo Parametric 2.0

erstellt am: 20. Apr. 2016 11:47    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Joshua63 10 Unities + Antwort hilfreich

Hallo Joshua,

hast du den üblichen Verdechtigen "fehlenden Verweise" schon überpüft?

Gruß
Bernd

EDIT: Stefan war schneller 

------------------
--- Man muß nicht alles wissen, man muß nur wissen wo es steht ---

Staatlich anerkannte Deutschniete  

[Diese Nachricht wurde von bk.sc am 20. Apr. 2016 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Joshua63
Mitglied
Maschinenbautechniker


Sehen Sie sich das Profil von Joshua63 an!   Senden Sie eine Private Message an Joshua63  Schreiben Sie einen Gästebucheintrag für Joshua63

Beiträge: 334
Registriert: 08.11.2006

erstellt am: 20. Apr. 2016 13:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Mahlzeit zusammen.......

ja ich weis, das hört sich total komisch an ist aber leider so.
Wir haben wirklich alles probiert, bei jeden gehts nur bei dem einen user nicht.
Es hapert beim Starten von Excel, denn die .TXT legt er ab.

Das mit den Verweisen prüfe ich noch mal.
Da das Makro auf dem Netz liegt und unser Admin behauptet alles rechner sind gleich installiert
kann es normalerweise auch daran nicht liegen.
Wenn alles nix bringt wird es wohl darauf hinaus laufen ein neues Profil zu erstellen.
Vielleicht liegt da ja der Hund begraben :-)

Danke für die schnellen Antworten

------------------
Viele Wege führen zum Ziel .......... und ich will alle wissen !

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

HenryV
Mitglied
Konstrukteur, Engineering


Sehen Sie sich das Profil von HenryV an!   Senden Sie eine Private Message an HenryV  Schreiben Sie einen Gästebucheintrag für HenryV

Beiträge: 564
Registriert: 18.05.2005

SolidWorks 2014 x64 SP5.0
Dell T3600 Workstation
Intel XENON 6x3.2 GHz
NVIDIA Quadro 4000 2 GB
16GB RAM
2x HP LP2065, 20" TFT
Windows 7 Professional x64 SP1
Microsoft Office Pro 2010 SP2
Kaspersky Anti-Virus 10.2.2.10535
Microsoft VB 2010 Express
SpacePilot von 3Dconnexion

erstellt am: 20. Apr. 2016 13:52    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Joshua63 10 Unities + Antwort hilfreich

Hallo Joshua

Falls es an Excel liegt überprüfe einmal,

... ob du eine eigene Excel-Standardvorlage hast?
Dann versuche es ohne diese.
Zu finden unter %appdata%\Microsoft\Excel\XLSTART

... ob spezielle Add-Ins installiert sind?
Dann deaktiviere einmal alle.
In Excel -> Datei -> Optionen -> Add-Ins -> Verwalten -> COM-Add-Ins -> Gehe zu

Gruss Andreas

------------------
21 ist nur die halbe Antwort.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Christian_W
Ehrenmitglied
Konstrukteur (Dipl-Ing)


Sehen Sie sich das Profil von Christian_W an!   Senden Sie eine Private Message an Christian_W  Schreiben Sie einen Gästebucheintrag für Christian_W

Beiträge: 1737
Registriert: 04.04.2001

(SWX 2016)
SWX 2012sp5 WIN7-64
proAlpha6.1d05/calinkV8
(Tactonworks)
(Medusa7, NesCAD2010,
solidEdge19)<P>CSWP 12/2015

erstellt am: 20. Apr. 2016 14:20    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Joshua63 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von Joshua63:
...
Der Debugger steht in der Zeile:  Set swApp=Aplication.sldWorks
...
Hat jemand eine Idee woran das liegen kann ?


Hallo,

Aplication.sldWorks mit einem "p" ?

Sonst: sind alle Netzlaufwerke bei dem Nutzer verfügbar?

Gruß, Christian

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Joshua63
Mitglied
Maschinenbautechniker


Sehen Sie sich das Profil von Joshua63 an!   Senden Sie eine Private Message an Joshua63  Schreiben Sie einen Gästebucheintrag für Joshua63

Beiträge: 334
Registriert: 08.11.2006

erstellt am: 21. Apr. 2016 15:24    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hi,

ups das war nur ein Schreibfehler.....

Das Problem hat sich erledigt, aber fragt mich nicht wie.

Nachdem ich dem user Adminrechte gegeben habe, klappte es.
Jetzt hab ich sie ihm wieder genommen und es geht immer noch.

Danke für eure Anregungen....

------------------
Viele Wege führen zum Ziel .......... und ich will alle wissen !

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2017 CAD.de