Forum:MegaCAD
Thema:Kinematik Probleme
Möchten Sie sich registrieren?
Wer darf antworten? Registrierte Benutzer können Beiträge verfassen.
Hinweise zur Registrierung Sie müssen registriert sein, um Beiträge oder Antworten auf Beiträge schreiben zu können.
Ihr Benutzername:
Ihr Kennwort:   Kennwort vergessen?
Anhang:    Datei(en) anhängen  <?>   Anhänge verwalten  <?>
Grafik für den Beitrag:                                                
                                                       
Ihre Antwort:

Fachbegriff
URL
Email
Fett
Kursiv
Durchgestr.
Liste
*
Bild
Zitat
Code

*HTML ist AUS
*UBB-Code ist AN
Smilies Legende
Netiquette

10 20 40

Optionen Smilies in diesem Beitrag deaktivieren.
Signatur anfügen: die Sie bei den Voreinstellungen angegeben haben.

Wenn Sie bereits registriert sind, aber Ihr Kennwort vergessen haben, klicken Sie bitte hier.

Bitte drücken Sie nicht mehrfach auf "Antwort speichern".

*Ist HTML- und/oder UBB-Code aktiviert, dann können Sie HTML und/oder UBB Code in Ihrem Beitrag verwenden.

T H E M A     A N S E H E N
weisj074

Beiträge: 2 / 0

Windows 7 Ultimate; SP1
Intel Core 2 Duo; 2,93GHz
4GB RAM; 32Bit;
NVIDIA Quadro 600<P>MegaCAD 2014 3D (32Bit)

Hallo zusammen,

versuche seit gestern mich mit Hilfe der MegaCAD Handbücher in die neue Kinematik einzuarbeiten. Grundsätzlich habe ich die meisten Bewegungen und Verknüpfungen verstanden (Glaube ich zumindestens  ).
Allerdings habe ich Probleme wenn ich versuche zwei Linearbewegungen nacheinander auszuführen.

Man stelle sich ein kartesisches Koordinatensystem vor (X/Y/Z)
Nun möchte ich z.B. vom Ursprung aus (0/0/0) mich gerade nach vorne bewegen (0/100/0) also entlang der Y-Achse.
Am Endpunkt angekommen möchte ich z.B. eine Bewegung nach rechts machen (100/100/0) also parallel zur X-Achse.
Eine einzelne Bewegung ist kein Problem aber sobald da mehrere in der Kinematik-Liste sind kommen zwei Fehlermeldungen:
- ODE-Debug1:assertion "bNormalizationResult" failed...
und
- ODE-Debug1:assertion "context -> IsStructureValid()" failed...

Ich vermute dass sich die beiden Bewegungen gegenseitig hemmen, auch wenn Sie nacheinander ausgeführt werden. Vielleicht liegt auch ein Fehler in der Verknüpfung der Bewegungen. Ich habe sowohl zeitgesteuerte als auch zustandsgesteuerte Ereignisse ausprobiert und auch die Linearbewegung einerseits mit paralleler Verbindung und andererseits Linearbewegung ohne paralleler Verbindung mit Schieber versucht.
Meine bisheriges Kinematikschema sah wie folgt aus:

- Statisch. Unbewegten Körper (Gruppe) definiert
- Linearmotor. Unbewegte und bewegte Körper (Gruppen) definiert. Auslöser: Start der Simulation
  Fahrt bis Abstand. Am Endpunkt Ereignis Event_1 festgelegt
- Linearmotor. Unbewegte und bewegte Körper (Gruppen) definiert. Auslöser: Event_1
  Fahrt bis Abstand.

Ich hoffe ich hab mich nicht zu kompliziert ausgedrückt

Vielen Dank schon für eure Mühe


Gruß

Jannik

Kopfkantenbruch

Beiträge: 150 / 0

MegaCAD Profi plus 2014/15
MegaCAD 2014/15 3D + Genial
Nvidia Quadro FX 1500
Spacetraveller

Hallo Jannik,

- richte Dir eine Hilfsgruppe ein
- baue einen kleinen Hilfskörper, der in der Hilfsgruppe liegt
- bewege den Hilfskörper entlang der Y-Achse relativ zur unbewegten Gruppe
- bewege Deinen eigentlich bewegten Körper entlang der X-Achse relativ zum Hilfskörper
- die Verbindung zwischen bewegtem Körper und unbewegtem Körper musst Du lösen!

Gruß Helge

weisj074

Beiträge: 2 / 0

Windows 7 Ultimate; SP1
Intel Core 2 Duo; 2,93GHz
4GB RAM; 32Bit;
NVIDIA Quadro 600<P>MegaCAD 2014 3D (32Bit)

Hallo Helge,

hat super funktioniert, vielen Dank!

Gruß Jannik

Kopfkantenbruch

Beiträge: 150 / 0

MegaCAD Profi plus 2014/15
MegaCAD 2014/15 3D + Genial
Nvidia Quadro FX 1500
Spacetraveller

Danke für die Rückmeldung, war ja eine sehr knapp formulierte Anleitung :-)