Forum:ELCAD
Thema:Import bei Zuordnungsliste plötzlich anders
Möchten Sie sich registrieren?
Wer darf antworten? Registrierte Benutzer können Beiträge verfassen.
Hinweise zur Registrierung Sie müssen registriert sein, um Beiträge oder Antworten auf Beiträge schreiben zu können.
Ihr Benutzername:
Ihr Kennwort:   Kennwort vergessen?
Anhang:    Datei(en) anhängen  <?>   Anhänge verwalten  <?>
Grafik für den Beitrag:                                                
                                                       
Ihre Antwort:

Fachbegriff
URL
Email
Fett
Kursiv
Durchgestr.
Liste
*
Bild
Zitat
Code

*HTML ist AUS
*UBB-Code ist AN
Smilies Legende
Netiquette

10 20 40

Optionen Smilies in diesem Beitrag deaktivieren.
Signatur anfügen: die Sie bei den Voreinstellungen angegeben haben.

Wenn Sie bereits registriert sind, aber Ihr Kennwort vergessen haben, klicken Sie bitte hier.

Bitte drücken Sie nicht mehrfach auf "Antwort speichern".

*Ist HTML- und/oder UBB-Code aktiviert, dann können Sie HTML und/oder UBB Code in Ihrem Beitrag verwenden.

T H E M A     A N S E H E N
kau

Beiträge: 296 / 13

 

Hallo,

diese Woche habe ich bemerkt, dass sich beim Import der ZuLi wohl etwas geändert hat.

Wir lesen Signale aus einer *.xls ein.

Eine Spalte der xls-Datei enthält Texte + Ganzzahlen z.B. "Ser.-Nr. 4711"
Bisher sind diese Ganzzahlen auch als solche im Elcad 771 angekommen, aber seit einigen Tagen hängt Elcad beim Import ein ".0" an.

  •   Im Elcad kommt jetzt an: "Ser.-Nr. 4711.0"
  •   Vor einiger Zeit war es noch "Ser.-Nr. 4711"

  •   In der xls-Datei ist die Spalte als "Standard" formatiert
  •   Im SPS-Konfigurator ist der Wert als "alphanumerisch" festgelegt

Woran kann das liegen? Das Problem tritt bei allen Kollegen auf.

Ich kann Elcad 760 nicht mehr testen, da auf FlexNet umgestellt wurde.

Vielen Dank für Hinweise
Uli

SMAH

Beiträge: 247 / 1

Hallo Uli,
vermutlich habt Ihr früher diese XLS Dateien anders formatiert bekommen oder erzeugt. Um zu verhindern das Excel automatisch Zahlenwerte generiert hilft meist nur ein ' (Apostroph) vor dem Zellenwert(Zellen auf Standard setzen bringt meist nichts). In deinem Fall sollte bei aktivierter Zelle in der Eingabezeige folgender Wert stehen 'Ser.-Nr. 4711 .Diese automatische Wandlung vom ODBC können wir leider nicht beeinflussen. Also: Wenn in Excel der Inhalt einer Zelle mit einem Apostroph beginnt (auch oft als “Hochkomma” bezeichnet), dann erzwingt dies, dass Excel den Inhalt als Text interpretiert.

------------------
Gruß
SMAH

kau

Beiträge: 296 / 13

 

Hallo,

danke, nach Änderung der Excel-Tabelle funktioniert der Import wieder ohne .0

Grüße
Uli