Forum:SolidWorks
Thema:SelectByID2 Fehlermeldung
Möchten Sie sich registrieren?
Wer darf antworten? Registrierte Benutzer können Beiträge verfassen.
Hinweise zur Registrierung Sie müssen registriert sein, um Beiträge oder Antworten auf Beiträge schreiben zu können.
Ihr Benutzername:
Ihr Kennwort:   Kennwort vergessen?
Anhang:    Datei(en) anhängen  <?>   Anhänge bearbeiten  <?>
Grafik für den Beitrag:                                                
                                                       
Ihre Antwort:

Fachbegriff
URL
Email
Fett
Kursiv
Durchgestr.
Liste
*
Bild
Zitat
Code

*HTML ist AUS
*UBB-Code ist AN
Smilies Legende
Netiquette

10 20 40

Optionen Smilies in diesem Beitrag deaktivieren.
Signatur anfügen: die Sie bei den Voreinstellungen angegeben haben.

Wenn Sie bereits registriert sind, aber Ihr Kennwort vergessen haben, klicken Sie bitte hier.

Bitte drücken Sie nicht mehrfach auf "Antwort speichern".

*Ist HTML- und/oder UBB-Code aktiviert, dann können Sie HTML und/oder UBB Code in Ihrem Beitrag verwenden.

T H E M A     A N S E H E N
Muck93

Beiträge: 16 / 0

Hallo Leute,

Ich habe eine Baugruppe geöffnet und ein weiteres Bauteil.
Ich möchte nun Abhängigkeiten setzten. Aber folgender Fehler tritt auf.
[CODE][ MateName = "Boden" + strCompName
            FirstSelection = "Ebene oben@" + strCompName & "@" + AssemblyName
            SecondSelection = "Front@" + AssemblyName


            swModel.ClearSelection2(True)
            swDocExt = swModel.Extension


            ' Select the planes for the mate
            boolstat = swDocExt.SelectByID2(FirstSelection, "PLANE", 0, 0, 0, True, 1, Nothing, swSelectOptionDefault)
            boolstat = swDocExt.SelectByID2(SecondSelection, "PLANE", 0, 0, 0, True, 1, Nothing, swSelectOptionDefault)/CODE]

1. Fehler: Beim swSelectOptionDefault: wurde nicht deklariert

Gruß

Carsten1210

Beiträge: 1312 / 0

AutoCAD ACA 2018
Solidworks 2016 Sp5
Enterprise PDM 2016 Sp5
Pascam Woodworks
Visual Studio 2017 Pro
Windows 10 64Bit
Dell T3620
Intel Core i7-7700K
16 GB Arbeitsspeicher
2x Samsung S24C650
Dell M4800

Hi Muck,

So wie es aussieht fehlt dir der Verweis auf die SWConst.tlb (Solidworks 201x Constant Typ Library).

Gruß, Carsten

[Diese Nachricht wurde von Carsten1210 am 27. Mai. 2017 editiert.]

Muck93

Beiträge: 16 / 0

Vielen Dank für deine Hilfe :-)