Forum:SolidWorks
Thema:API: Wann liefert ActiveDoc NULL?
Möchten Sie sich registrieren?
Wer darf antworten? Registrierte Benutzer können Beiträge verfassen.
Hinweise zur Registrierung Sie müssen registriert sein, um Beiträge oder Antworten auf Beiträge schreiben zu können.
Ihr Benutzername:
Ihr Kennwort:   Kennwort vergessen?
Anhang:    Datei(en) anhängen  <?>   Anhänge bearbeiten  <?>
Grafik für den Beitrag:                                                
                                                       
Ihre Antwort:

Fachbegriff
URL
Email
Fett
Kursiv
Durchgestr.
Liste
*
Bild
Zitat
Code

*HTML ist AUS
*UBB-Code ist AN
Smilies Legende
Netiquette

10 20 40

Optionen Smilies in diesem Beitrag deaktivieren.
Signatur anfügen: die Sie bei den Voreinstellungen angegeben haben.

Wenn Sie bereits registriert sind, aber Ihr Kennwort vergessen haben, klicken Sie bitte hier.

Bitte drücken Sie nicht mehrfach auf "Antwort speichern".

*Ist HTML- und/oder UBB-Code aktiviert, dann können Sie HTML und/oder UBB Code in Ihrem Beitrag verwenden.

T H E M A     A N S E H E N
clausb

Beiträge: 2889 / 0

Ich schreibe das hier in meiner Freizeit und spreche weder für meinen Arbeitgeber noch für andere Firmen. Mehr Unsinn von mir unter clausbrod.de.

Hallo,

wir versuchen gerade einem Problem auf den Grund zu gehen, das wir inzwischen zumindest soweit heruntergebrochen haben, dass wir wissen, dass es alles damit anfängt, dass ISldWorks.ActiveDoc unerwarteterweise NULL liefert, obwohl wir eigentlich ein aktives Dokument haben sollten.

Die offizielle Doku sagt nicht viel zu dem Thema, in welchen Situationen NULL geliefert wird, aber meine Hoffnung ist, dass es dazu in diesem Forum bereits einschlägige Erfahrungen gibt. Jeder Hinweis willkommen.

Danke!

  Claus

PS: Getestet haben wir bisher in SolidWorks 2014 (64-Bit-Version) unter Windows 7. Weitere Konfigurationsdaten liefere ich gerne, wenn benötigt.

------------------
CoCreate Modeling FAQ: http://www.clausbrod.de/CoCreateModeling/

Lutz Federbusch

Beiträge: 3083 / 33

alle SW seit 97+
AutoCAD2016
ERP ProAlpha + CA-Link
Intel Core i7 860 16GB
Win7x64 QuadroFX1800
SpacePilot

Eine mögliche Ursache könnte eine zweite (evtl. vorher abgestürzte) laufende Sitzung von SolidWorks sein, die dann leider gerade kein aktives Dokument hat... Im Taskmanager könnte man jedenfalls mal nachsehen, wie bei Auftreten des Fehlers die Lage ist.

------------------
Lutz Federbusch
Mein Gästebuch
Der Mensch, Herr oder Sklave der Technik?