Forum:CATIA V5 Programmierung
Thema:Selektion in der Schleife läuft auf Fehler
Möchten Sie sich registrieren?
Wer darf antworten? Registrierte Benutzer können Beiträge verfassen.
Hinweise zur Registrierung Sie müssen registriert sein, um Beiträge oder Antworten auf Beiträge schreiben zu können.
Ihr Benutzername:
Ihr Kennwort:   Kennwort vergessen?
Anhang:    Datei(en) anhängen  <?>   Anhänge verwalten  <?>
Grafik für den Beitrag:                                                
                                                       
Ihre Antwort:

Fachbegriff
URL
Email
Fett
Kursiv
Durchgestr.
Liste
*
Bild
Zitat
Code

*HTML ist AUS
*UBB-Code ist AN
Smilies Legende
Netiquette

10 20 40

Optionen Smilies in diesem Beitrag deaktivieren.
Signatur anfügen: die Sie bei den Voreinstellungen angegeben haben.

Wenn Sie bereits registriert sind, aber Ihr Kennwort vergessen haben, klicken Sie bitte hier.

Bitte drücken Sie nicht mehrfach auf "Antwort speichern".

*Ist HTML- und/oder UBB-Code aktiviert, dann können Sie HTML und/oder UBB Code in Ihrem Beitrag verwenden.

T H E M A     A N S E H E N
bgrittmann

Beiträge: 11032 / 18

CATIA V5R19

Servus Erich

Arbeite mal die Schleife von hinten nach vorne ab. Sonst kommt der Zähler etwas durcheinander (die höheren Nummern gibt es nicht mehr).

Code:
For i = Selection1.Count to 1 Step -1

Des weiteren: es gibt nur eine Selektion. Wenn du im ersten Schleifendruchlauf mit Delete alle Elemente löschst oder per Clear alles deselkierts ist ja nichts mehr selektiert du die Schleife läuft in einen Fehler.
Vorschlag: Schleife über die Selektion (von hinten nach vorne laufen lassen), wenn der Körper die Bedingung NICHT erfüllt (Hauptkörper, Elemente im Körper, ...) diesen aus der Selektion entfernen (Remove).
Nach der Schleife über Delete alle noch selektierten Elemente löschen.

Gruß
Bernd

------------------
Warum einfach, wenn es auch kompliziert geht.