Externe Referenzen nicht im Kontext! / SolidWorks
mfaes 16. Apr. 2020, 11:26

Hallo zusammen

Ich habe mir eine Skeleton-Datei erstellt mit vielen Punkte und Linien, die ich in einer Baugruppe eingefügt habe. In dieser Baugruppe habe ich neue Bauteile erstellt und mit den Linien und Punkten aus der Skeleton-Datei verlinkt.
Nun, ein Tag später erscheinen mir die Bauteile mit den externen Referenzen im Status "Nicht im Kontext". Die Bauteile zeigen mir aber die Externen Referenzen der Skeleton-Datei und Baugruppe an. Die zwei Dateien, Skeleton-Datei und Baugruppe habe ich auch geladen.
Also wieso erkennen die Bauteile die Referenzen nicht mehr obwohl alles vorhanden ist. Komisch ist auch, dass es nicht bei allen Bauteilen der Fall ist.

Gruss
Michael

Ralf Tide 16. Apr. 2020, 14:12

Hallo Michael,
was wird Dir denn bei 'Referenzen suchen...' angezeigt?

mfaes 16. Apr. 2020, 14:36

Hallo Ralf

Momentan habe ich wieder alle externen Referenzen (neu erstellt).
Den Befehl 'Referenzen suchen' kannte ich bis jetzt nicht.
Sobald ich das Problem wieder habe, schau ich was da angezeigt wird.

Danke und Gruss
Michael

mfaes 16. Apr. 2020, 15:08

Hallo Ralf

So, habe noch zwei Modelle gefunden, die im Status "Nicht im Kontext" sind. Beim "Referenzen suchen" werden aber die Referenzen korrekt angegeben so wie auch, wenn ich im Model "externe Referenzen" anklicke.

Gruss
Michael

mfaes 28. Apr. 2020, 07:54


ExterneReferenzen.JPG

 
Hallo

Nun habe ich das Problem schon wieder. Im Menü "externe Referenzen" werden mir die Referenzen als "nicht im Kontext" angegeben. SolidWorks gibt mir aber an von wo die Referenzen stammen (siehe Bild im Anhang). Wenn ich die Referenz-Datei lade erkennt SolidWorks die Referenzen dennoch nicht. Gibt es eine Möglichkeit die Verbindung manuell wiederherzustellen?

Danke und Gruss
Michael

freierfall 28. Apr. 2020, 08:39

buhh, klingt aber echt seltsam folgend mein Ideen/Fragen:

- welches SP von SWX2019 ist installiert?
- du schreibst PDM Prof. hast du alle nötigen Rechte, damit du die Teile bearbeiten drafst?
- ich kenne ich mich mit PDM Prof. nicht aus, kann man da neuere Stände ausversehen durch alte Stände überschreiben?
- Hast du im Zusammenhang mit dem PDM Prof. irgendwelche Meldungen ausgeblendet?
- Kann ein Kollege deine Arbeit überschrieben haben mit einem altem Stand?
- kann man nur im Schreibschutzmodus Dateien öffnen im SWX? Weiß ich gerade nicht.

herzlich Sascha

[Diese Nachricht wurde von freierfall am 28. Apr. 2020 editiert.]

mfaes 28. Apr. 2020, 10:39

Hallo Sascha

Ich arbeite mit SWX2019SP3.0 und habe alle Berechtigungen im PDM Prof.

So, nun habe ich doch herausgefunden woran es liegt, dass die Externen Referenzen nicht mehr verknüpft sind. Ich habe die Parts im „reduziertem Zustand“ von der Oberbaugruppe in die Unterbaugruppe verschoben. Als ich danach von „reduziert“ auf „vollständig“ umgeschaltet habe, erschien das „?“.
So weit so gut. Wie kriege ich nun aber meine Verlinkungen wieder?
Gruss
Michael

[Diese Nachricht wurde von mfaes am 28. Apr. 2020 editiert.]

Christian_W 28. Apr. 2020, 12:24

Hallo,

wie wäre es mit einem Screenshot vom Featurebaum der Baugruppe und dem ganzen Fenster der externen Referenzen?
da stehen ja noch ein paar Einträge, z.B. der Kontext in dem die Referenzen gültigt sind, für welche Komponente sie definiert sind, ...
z.B. ist Komponente_A<1> was anderes als Komponente_A<2> ...

die Frage ist ungefähr so präzise wie "warum fährt mein Auto nicht?"

Gruß, Christian

mfaes 28. Apr. 2020, 12:47

Hallo Christian

Die Frage ist präzise. Ich weiss warum’s passiert ist (Part im „reduziertem Zustand“ von der Oberbaugruppe in die Unterbaugruppe verschoben, danach Verlinkung futsch) und frage nun, kann man die Verlinkungen retten? Manuell geht es, braucht einfach enorm viel Zeit.

Danke und Gruss
Michael

freierfall 28. Apr. 2020, 12:53

- den älteren pdm Stand vor der Verschiebung nur die Baugruppe runterladen.

Christian_W 28. Apr. 2020, 13:11

Zitat:
Original erstellt von mfaes:
... Part im „reduziertem Zustand“ von der Oberbaugruppe in die Unterbaugruppe verschoben, danach Verlinkung futsch ...

also von verschieben in Unterbaugruppe lese ich jetzt gerade zum ersten mal ... soviel zu "präzise" ...

Edith - ok, es steht als Zusatzerkenntnis im letzten Post vor meinem, der muss erschienen sein, während ich den Tab offen hatte.
Mit einem oder 2 aussagefähigen Screenshot(s) gleich zu Anfang hätte man das vermutlich schneller erkennen können.

[Diese Nachricht wurde von Christian_W am 29. Apr. 2020 editiert.]

Hans Mueller 29. Apr. 2020, 07:51

Da ich viel mit externen Referenzen arbeite kommt mir das Problem durchaus bekannt vor. Meine Lösung:
Teil im Kontext der Baugruppe öffnen, Skizze öffnen, 1 Skizzenelement auswählen, in den Eigenschaften 1 x fixiert hinzufügen und gleich wieder löschen, Skizze schließen, Teil schließen. SWX rechnet jetzt die Skizze im Kontext neu und meistens sind die Referenzen dann wieder korrekt.
Geht auf jeden Fall schneller als alles neu zu erstellen.

mfaes 29. Apr. 2020, 09:00

Hallo

Unterdessen habe ich alle Referenzen aus der Unterbaugruppe heraus neu erstellt und momentan funktionierts.

Vorgängig habe ich es nochmals versucht die Parts in eine Unterbaugruppe zu verschieben. Dazu habe ich aber zuerst alle Daten vollständig geladen. Dennoch wurden nicht bei allen Parts die Referenzen korrekt mitgenommen. Als ich die Parts in die ursprüngliche Baugruppe zurückschob, waren die Reverenzen wieder vorhanden.

Ich glaube SolidWorks hat einfach ein Problem, wenn man Parts mit externen Referenzen in eine Unterbaugruppe verschiebt.

Gruss
Michael

Christian_W 29. Apr. 2020, 13:12

Zitat:
Original erstellt von mfaes:
...
Ich glaube SolidWorks hat einfach ein Problem, wenn man Parts mit externen Referenzen in eine Unterbaugruppe verschiebt...

Ja, das ist keine so gute Idee.
auch beim "Speichern unter" kann das schon mal schief gehen oder wenn man Komponenten mehrfach drin hat und mal in der einen und mal in der anderen im Kontext bearbeitet - oder wenn jemand Dateien umbenennt ...

fürs Speichern von Baugruppen mit Komponenten und Anpassung der Referenzen gibt es "Pack and Go" (und in unserem PDM "Klonen")
Um Referenzen zu ändern gibt es im "Datei-Öffnen-Dialog" Optionen oder irgendwo ein Tool "RepairReference.exe"
(http://solidworks.cad.de/programme.htm)

Gruß, Christian