Artikeldatenbank - Unterschiedliche Eigenschaften bei Kabeln / EPLAN Electric P8
MaikWald 14. Jul. 2020, 13:48


Typ1.png


Typ2.png

 
Ich versuche Ordnung in eine historisch gewachsene Datenbank zu bekommen.
Leider gibt es Kabel bei denen es zusätzliche Eigenschaftsfelder (Zeile 25-34) gibt.
Bei Artikeln, welche diese Felder nicht haben, wird merkwürdigerweise auch der Typ (bzw. "Bezeichnung 1") nicht in der Stückliste angezeigt.
Die Produktgruppen und Gewerke sind überall identisch (E-Technik / Kabel / Allgemeine / E-Technik)
Die Datenbank ist ein SQL Server.

Hat jemand eine Idee zur Ursache?

F.S. 14. Jul. 2020, 15:39

Hallo,

Das sind Eigenschaften die durch den Import aus dem Data Portal gekommen sind.
Selber kann man diese nicht anlegen.

MaikWald 15. Jul. 2020, 08:59

Hm okay, aber warum wird dann die "Bezeichnung 1" bei diesen nicht im Stücklistennavigator (siehe Bild rechte Seite) angezeigt (Angabe in Klammern hinter der Artikelnummer)?
Geht das nur bei aus dem Data Portal importierten Artikeln?
Kann ich das irgendwo konfigurieren?

Croonain 15. Jul. 2020, 09:23

Wenn du aus der Artikelauswahlliste einen Rechtsklick auf den Artikel machst, dann auf Darstellung konfigurieren, kannst du anschließend ein Schema auswählen oder ein neues erstellen.

z.B. Artikelnummer(Artikel: Bezeichnung 1)

davy gabriels 15. Jul. 2020, 10:07

Zitat:
Original erstellt von MaikWald:
Hm okay, aber warum wird dann die "Bezeichnung 1" bei diesen nicht im Stücklistennavigator (siehe Bild rechte Seite) angezeigt (Angabe in Klammern hinter der Artikelnummer)?
Geht das nur bei aus dem Data Portal importierten Artikeln?
Kann ich das irgendwo konfigurieren?


Sind deine Projektartikelen synchroniert mit diesen aus Artikeldb?

MaikWald 17. Jul. 2020, 09:23

@Croonain, Danke für den Hinweis.
Hab ich überprüft und passt soweit. Es scheint wirklich das Problem zu sein, dass bei manchen Artikel die "Artikelreferenzdaten":"Bezeichnung 1" leer ist, obwohl die Artikeldaten alle komplett sind.

@davy Gabriels: Im Dialog "Dienstprogramme/Artikel/Aktuelles Projekt abgleichen..." sind die Datensätze identisch.

Sehr merkwürdig.
Keine große Sache aber kann doch nicht sein, dass es einfach nicht hinzukriegen ist