Stapel Texte tauschen Bug / ELCAD
HRompel 26. Jan. 2013, 08:42

Moin,

zwei mal hintereinander Texte tauschen im Stapel ist immer noch fehlerhaft.
Tauschen 1: EB334 nach EB331
Tauschen 2: EB337 nach EB332
beim Anlegen funktioniert es noch. Es wird auch richtig ausgeführt.

Aber, öffnet man den Stapel und will beide Aktionen bearbeiten, steht in beiden das gleiche.

Gruß Heiko

domTRON 28. Jan. 2013, 08:36

Ist das nicht eine grundsätzliche Eigenschaft von ELCAD, dass in den Dialogen immer die letzten gemachten Angaben drinstehen? Das bedeutet allerdings nicht, dass diese Angaben in der Stapelfunktion so hinterlegt sind.

Das ist speziell bei den Stapeln recht störend, denn wenn ich ein fremdes Projekt öffne, muss ich bei kleinen Änderungen im Prinzip alles neu anlegen oder den komplizierten Weg gehen und eine Anweisungsdatei schreiben, ändern und wieder einlesen.

(Ich weiß, Stapel sind generell kritisch, weil ein Jeder diese anders benutzt und da irgendeinen Unsinn reinschreibt. Leider MUSS ich damit arbeiten  )

Pelle Bootsmann 28. Jan. 2013, 09:43

Hallo Heiko,

nach dem Erstellen des Stapel wird dieser auch funktionieren.
Sieht man sich den Stapel mit "Detailinfo" an, so ist auch alles richtig.

Das eigentliche Problem tritt erst auf wenn man auf "Ändern" geht. Hier wird
nämlich nicht der Inhalt des Stapels angezeigt, sondern die letzte Einstellung
die in der aucotec.ini abgespeichert ist. Drückt man nun "Ok", dann wird diese
letzte Einstellung in den Stapel geschrieben und der Stapel eventuell ungewollt
verändert.

Das Problem ist schon in der ReDa gelistet und für die 7.9 geplant. (EL-111010-110,EL-12121-002)